[Openvas-devel] [openvas-Bugs][954] Empty reports in Ubuntu 8.10

openvas-bugs at wald.intevation.org openvas-bugs at wald.intevation.org
Mon Apr 13 04:40:16 CEST 2009

Bugs item #954, was opened at 2009-04-13 02:40
Status: Open
Priority: 3
Submitted By: Andrew S (andrew9)
Assigned to: Nobody (None)
Summary: Empty reports in Ubuntu 8.10 
Resolution: None
Severity: blocker
Version: v2.0.1
Component: None
Operating System: Linux
Product: OpenVAS
Hardware: Other

Initial Comment:
Symptom: Reports are empty in Ubuntu 8.10.

Packages installed: server 2.0.1, plugins 1.0.6, libraries 2.0.1, libnasl 2.0.1, client 2.0.3. All packages were installed from source on Ubuntu 8.10 desktop edition, with server and client on the same machine. All dependencies were satisfied during compilation. A certificate was generated using openvas-mkcert, and a user with no testing restrictions was created using openvas-adduser.

To replicate:

1. Start the server from the command line by typing "sudo openvasd". Wait for plugins to load.
2. Start the client from the main menu.
3. Connect to the server using your username and key password.
4. Set the number of concurrent tests (I tried 1 and 4 with the same result). Check the boxes indicating to load dependencies automatically and to do so silently.
5. Select the NVTs to be conducted.
6. Open the assistant from the File menu. Enter the required information, including the IP address of the remote machine, and begin the test.
7. At the prompt, enter your key password again to connect.

The test will begin, and the progress-bar popup will appear. At this point, Wireshark will confirm that the OpenVAS server is indeed probing the remote machine. The progress-bar popup will then disappear, and an entry for the report will appear in the lefthand pane.

8. Click on the entry for the report, which will be empty.

If you look at openvasd.messages, the log entries will indicate "user starts a new scan... user testing... finished testing... test complete." openvasd.dump may (1) show that you didn't SSH-authenticate for local tests on the remote machine (but I wasn't doing local tests) and (2) list a bunch of irrelevant plugin dependencies that weren't satisfied.

Please let me know if I can provide any more information.


You can respond by visiting: 

More information about the Openvas-devel mailing list