[Openvas-devel] openvas-libraries 2.0.4 broken on Ubuntu 10.04

Stephan Kleine bitdealer at gmail.com
Wed May 5 20:47:05 CEST 2010


On Wednesday May 5 2010 19:30:17 Jan-Oliver Wagner wrote:
> On Tuesday 04 May 2010 21:05:30 Stephan Kleine wrote:
> > Hi guys,
> > 
> > building openvas-libraries 2.0.4 for Ubuntu 10.04 failed with
> > 
> > ...
> > installing libpcap0.8-dev
> > ...
> > checking for gnutls_init in -lgnutls... yes
> > checking for pcap_restart in -lpcap... no
> > configure: error: you need to install pcap library with development files
> > make: *** [config.status] Error 1
> > dpkg-buildpackage: error: debian/rules build gave error exit status 2
> > 
> > Attached patch changes the pcap check from pcap_restart (which you don't
> > use anyways) to pcap_datalink.
> > 
> > Are there any objections against applying this?
> 
> in trunk the test now reads
> AC_CHECK_LIB(pcap, pcap_version, LIBS="-lpcap $LIBS",
> 
> Maybe this works for the old 2.0 on Ubuntu as well?

Yup, that works fine too. I updated configure.in in /branches/openvas-
libraries-2-0 to use pcap_version.
 
> Best
> 
> 	Jan
> _______________________________________________
> Openvas-devel mailing list
> Openvas-devel at wald.intevation.org
> http://lists.wald.intevation.org/mailman/listinfo/openvas-devel


More information about the Openvas-devel mailing list