[Openvas-devel] [openvas-Bugs][1909] Fedora 14 requires -lgthread-2.0

openvas-bugs@wald.intevation.org openvas-bugs at wald.intevation.org
Mon Jan 3 16:09:15 CET 2011


Bugs item #1909, was opened at 2011-01-03 10:09
Status: Open
Priority: 3
Submitted By: Scott Shinn (atomicturtle)
Assigned to: Nobody (None)
Summary: Fedora 14 requires -lgthread-2.0 
Architecture: None
Resolution: None
Severity: major
Version: None
Component: gsa-desktop
Operating System: None
Product: OpenVAS
Hardware: None
URL: http://fedoraproject.org/wiki/UnderstandingDSOLinkChange


Initial Comment:
New linking behaviour in FC14, from the change summary:

"The default behaviour for ld allows users to 'indirectly' link to required objects/libraries through intermediate objects/libraries. While this is convenient, it can also be dangerous because it makes your program's dependencies tied to the dependencies of other objects. If those objects ever change their linkages, they can break your program without any changes to your own code! "

----------------------------------------------------------------------

You can respond by visiting: 
http://wald.intevation.org/tracker/?func=detail&atid=220&aid=1909&group_id=29


More information about the Openvas-devel mailing list