[Openvas-discuss] unable to rsync NVT's

Glenn Bell glenn.s.bell at gmail.com
Fri Oct 9 16:47:28 CEST 2009


Do you have a proxy server?  If so, you can set RSYNC_PROXY.  From the
rsync(1) man page:

You may establish the connection via a web proxy by setting  the
environment variable RSYNC_PROXY to a hostname:port pair pointing to
your web proxy.  Note that your web proxy’s configuration must support
proxy connections to port 873.

	export RSYNC_PROXY="proxy.mydomain.org:8080"

You  may  also establish a daemon connection using a program as a proxy
by setting the environment variable RSYNC_CONNECT_PROG to the commands
you wish to run in place of making a direct socket connection.  The
string may contain the escape “%H” to represent the hostname  specified
in the rsync command (so use “%%” if you need a single “%” in your
string). For example:

	export RSYNC_CONNECT_PROG=’ssh proxyhost nc %H 873’
	rsync -av targethost1::module/src/ /dest/
	rsync -av rsync:://targethost2/module/src/ /dest/

       The command specified above uses ssh to run nc (netcat) on a
proxyhost, which  forwards all data to port 873 (the rsync daemon) on
the targethost (%H).

My proxy server supports port 873, so the first method worked for me.

The second method assumes a host that accepts ssh connections from the
inside and has Internet connectivity on port 873.

I would explore these methods before disabling your firewall, after all
we are trying to improve overall security :)

-Glenn

Michael Meyer wrote:
> *** tanishk lakhaani <tanishk.lakhaani at mca.gov.in> wrote:
>> I tried what u said, but this is the error that I receive
>>
>> telnet rsync.openvas.org 873
>>
>> Connecting to rsync.openvas.or...Could not open connection to the host, o
>> port 873: Connect failed.
> 
> Looks for me like a problem with your firewall. Do you have a local
> firewall? If yes, please disable and try again. 
> 
> Micha
> 






More information about the Openvas-discuss mailing list