[Openvas-discuss] Problem with OpenVAS 2.0.3

Isabella Disley ixhd at rogers.com
Fri Sep 18 14:47:39 CEST 2009


Hi Chandra,
I am using 2.0.4.
These are the packages I installed;
-rw-r--r--  1 root  root   1955840 Sep 11 14:09 openvas-server-2.0.3.tar
-rw-r--r--  1 root  root  55930880 Sep 11 14:09
openvas-plugins-1.0.7.tar
-rw-r--r--  1 root  root   2467840 Sep 11 14:09
openvas-libraries-2.0.4.tar
-rw-r--r--  1 root  root   2549760 Sep 11 14:09
openvas-libnasl-2.0.2.tar
-rw-r--r--  1 root  root   3942400 Sep 11 14:09 openvas-client-2.0.5.tar

Contents of my "lib" directory;

/opt/openvas2/lib

-rwxrwxrwx 1 root openvas 715560 Sep 16 11:57 libopenvasnasl.a
-rwxrwxrwx 1 root openvas   1026 Sep 16 11:57 libopenvasnasl.la
lrwxrwxrwx 1 root openvas     23 Sep 16 11:57 libopenvasnasl.so ->
libopenvasnasl.so.2.0.2
lrwxrwxrwx 1 root openvas     23 Sep 16 11:57 libopenvasnasl.so.2 ->
libopenvasnasl.so.2.0.2
-rwxrwxrwx 1 root openvas 543714 Sep 16 11:57 libopenvasnasl.so.2.0.2
-rwxrwxrwx 1 root openvas  21508 Sep 16 11:23 libopenvas_hg.a
-rwxrwxrwx 1 root openvas    920 Sep 16 11:23 libopenvas_hg.la
lrwxrwxrwx 1 root openvas     22 Sep 16 11:23 libopenvas_hg.so ->
libopenvas_hg.so.2.0.4
lrwxrwxrwx 1 root openvas     22 Sep 16 11:23 libopenvas_hg.so.2 ->
libopenvas_hg.so.2.0.4
-rwxrwxrwx 1 root openvas  21961 Sep 16 11:23 libopenvas_hg.so.2.0.4
-rwxrwxrwx 1 root openvas 412562 Sep 16 11:23 libopenvas.a
-rwxrwxrwx 1 root openvas    910 Sep 16 11:23 libopenvas.la
lrwxrwxrwx 1 root openvas     19 Sep 16 11:23 libopenvas.so ->
libopenvas.so.2.0.4
lrwxrwxrwx 1 root openvas     19 Sep 16 11:23 libopenvas.so.2 ->
libopenvas.so.2.0.4
-rwxrwxrwx 1 root openvas 552678 Sep 16 11:23 libopenvas.so.2.0.4
Cheers,
Mark

--- On Fri, 9/18/09, Chandrashekhar B <bchandra at secpod.com> wrote:

From: Chandrashekhar B <bchandra at secpod.com>
Subject: RE: [Openvas-discuss] Problem with OpenVAS 2.0.3
To: "'Isabella Disley'" <ixhd at rogers.com>, openvas-discuss at wald.intevation.org
Received: Friday, September 18, 2009, 1:12 AM

Mark,

Can you try with openvas-libraries-2.0.4 (2.0.3 has plug_get_mandatory_keys
missing).

Thanks,
Chandra.

________________________________________
From: openvas-discuss-bounces at wald.intevation.org
[mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of Isabella
Disley
Sent: Friday, September 18, 2009 7:47 AM
To: openvas-discuss at wald.intevation.org
Subject: [Openvas-discuss] Problem with OpenVAS 2.0.3

Greetings,
Just upgraded OpenVAS on my Fedora 8 machine.  All packages and libraries
compiled without any errors.  Server drops the connection as soon after I
start a scan using the CLI with this error;
Communication closed by server
OpenVAS-Client: The server abruptly shut the communication down - the test
may be incomplete

openvasd.dump records this entry;
openvasd: serving 127.0.0.1: symbol lookup error: openvasd: serving
127.0.0.1: undefined symbol: plug_get_mandatory_keys

openvasd.messages records this entry;
[Thu Sep 17 13:36:50 2009][29871] connection from 127.0.0.1 
[Thu Sep 17 13:36:50 2009][29894] Client requested protocol < OTP/1.0 >. 
[Thu Sep 17 13:36:50 2009][29894] successful login of scanner20 from
127.0.0.1 

System is  
Linux 2.6.26.8-57.fc8 #1 SMP
 Thu
 Dec 18 18:50:02 EST 2008 i686 i686 i386GNU/Linux
Any thoughts?

Please and Thanks

Mark


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20090918/7f469273/attachment.html>


More information about the Openvas-discuss mailing list