[Openvas-discuss] Problem with Authentication of the OV Manager at the Scanner

birkel at fh-brandenburg.de birkel at fh-brandenburg.de
Sun Aug 8 17:50:56 CEST 2010


Quoting Matthew Mundell <matthew.mundell at greenbone.net>:

>> i tried to communicate with the manager over omp
>>
>> via the command 'omp -v --pretty-print --xml="<get_status/>"'
>>
>> but i get this back:
>>
>> <omp_response status="400" status_text="Bogus command name"></omp_response>
>>
>> but im sure that worked on the boss live cd
>>
>> the manager logs the following line
>>
>> md omp:MESSAGE:2010-08-08 09h30.32 utc:1494: Failed to parse client  
>> XML: Error
>>
>> ok, i see - in version 1.0 of the omp there is no command GET_STATUS
>>
>> so it seems there is a problem authemticate the openvas manager at  
>> the scanner
>
> Looks like the authentication succeeded.  What happens when you use a real
> command, like GET_TASKS or HELP?
>
> 	omp -v --pretty-print --xml="<get_tasks/>"
>
hi matthew,

the communication over omp with the manager works.
my problem still the communication between the manager and the scanner.
when i start the manager i get an error and the log shows a  
authentification failure. i used the gsa to create a task, but i  
couldn't start it.

by the way - is it necessary to install the openvas administrator, if  
i want to use the full greenbone security agent?


----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.





More information about the Openvas-discuss mailing list