[Openvas-discuss] Problem with Authentication of the OV Manager at the Scanner

birkel at fh-brandenburg.de birkel at fh-brandenburg.de
Mon Aug 9 09:48:03 CEST 2010


Zitat von Michael Wiegand <michael.wiegand at greenbone.net>:

> Am Sonntag, 8. August 2010 17:50:56 schrieb birkel at fh-brandenburg.de:
>> the communication over omp with the manager works.
>> my problem still the communication between the manager and the scanner.
>> when i start the manager i get an error and the log shows a
>> authentification failure. i used the gsa to create a task, but i
>> couldn't start it.
>>
>> by the way - is it necessary to install the openvas administrator, if
>> i want to use the full greenbone security agent?
>
> At a glance, I think you have not yet created any users beside the
> internal "om" user. Is this correct?
>
> You do indeed need to create a "normal" user to use the manager;
> openvas-administrator is the recommended tool for this, especially if you
> want to have the full gsa setup.
>
> Regards,
>
> Michael
>
> --
> Michael Wiegand |  Greenbone Networks GmbH  |  http://www.greenbone.net/
> Neuer Graben 17, 49074 Osnabrück, Germany | AG Osnabrück, HR B 202460
> Executive Directors: Lukas Grunwald, Dr. Jan-Oliver Wagner
>
>
greetings Michael,

i created a "second" user with the help of the openvas-adduser script,  
to communicate with the manager. i used this account for testing the  
communication with the manager over the omp command line tool.

whether i start the manager daemon over the start script  
/etc/init.d/openvas-manager or i start the openvasmd with parameter,  
it logs the failure:
Authentication configuration could not be loaded


Regards Dennis

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.




More information about the Openvas-discuss mailing list