[Openvas-discuss] openvasmd doesn't run after update

Stefan Schwarz Stefan.Schwarz at unibw.de
Sun Aug 15 11:12:23 CEST 2010


Am 15.08.2010 10:13, schrieb Hartmut Goebel:
> Am 15.08.2010 09:53, schrieb Stefan Schwarz:
>> I just updated to SVN 8806. When starting openvasmd i get (expected)
>> errors indicating that database has to be updated:
> [...]
>> update_or_rebuild_nvt_cache: database is wrong version
>
> For updating th database version (= scheme), you need to run openvasmd
> with the --migrate option.

That's it! openvasmd runs fine. Maybe there should be a hint in the logs 
about using --migrate.
>
>> But openvasmd --update and openvasmd --rebuild don't work as they
>> produce the same error messages. So i decided to build a completely new
>> database by removing old tasks.db and executing openvasmd --rebuild. But
>> this leads to:
> [...]
>> md   main:  DEBUG:2010-08-15 07h41.26 utc:27466: sign: stderr: gpg:
>> no default secret key: Geheimer Schlüssel ist nicht vorhanden
>
> On this part I anybody else has to help.
>

Please fix it, because with current release no one will be able to build 
a new valid database.

	Stefan

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6299 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20100815/6b4994e0/attachment.p7s>


More information about the Openvas-discuss mailing list