[Openvas-discuss] Manager can't update/rebuild DB: database table is locked

LC W elceedub at gmail.com
Fri Aug 27 20:47:26 CEST 2010


Hello all.  I've built and installed openvas-libraries-3.1.2,
openvas-scanner-3.1.0, and openvas-manager-1.0.2 from source on
RHEL5.5.  I created the "om" account/certs per the README, and started
openvassd on port 9391, then tried to do a rebuild of the manager
database by running "openvasmd --sport 9391 --rebuild --verbose".  If
I watch the manager log, I see that it connects to the scanner, and
then a bunch of SQL statements as if the manager is building it's
database.  This does not complete, however.  The last bit of the log
looks like this:

md   main:  DEBUG:2010-08-27 17h41.47 utc :21657:    sql: UPDATE
configs SET family_count = 2, nvt_count = 3, families_growing = 1,
nvts_growing = 1 WHERE name = 'Full and fast';

md   main:WARNING:2010-08-27 17h41.47 utc :21657: sql: sqlite3_step
failed: database table is locked

md   main:CRITICAL:2010-08-27 17h41.47 utc :21657: handle_sigabrt: abort

md   main:  DEBUG:2010-08-27 17h41.47 utc :21657:    Cleaning up.

md   main:  DEBUG:2010-08-27 17h41.47 utc :21657:    Exiting.

The current sqlite version on RHEL5 is 3.3.6-5.  I've tried to do the
--update as well, and it fails in the same place.  The manager refuses
to start, and tells me to run and update or rebuild.  Any ideas?

-kml



More information about the Openvas-discuss mailing list