[Openvas-discuss] Openvas libraries 3.0.5

Toan Nguyen tnguyen at slacker.com
Tue Jun 22 01:02:13 CEST 2010


Thanks for the response. I also have the latest compilation of
libgpg-error, version 1.8. 

-----Original Message-----
From: Nigel Taylor [mailto:njtaylor at asterisk.demon.co.uk] 
Sent: Friday, June 18, 2010 6:44 PM
To: Toan Nguyen
Cc: openvas-discuss at wald.intevation.org
Subject: Re: [Openvas-discuss] Openvas libraries 3.0.5

Hi,

The problem looks like it's is with libgpg-error, either a later version
is
needed by gpgme or picking up an earlier version first. What I have for
OpenBSD is

$ pkg_info -I openvas-libraries glib2 gnutls gpgme libgpg-error
openvas-libraries-3.0.5
glib2-2.24.1
gnutls-2.8.6
gpgme-1.1.5p0
libgpg-error-1.7
$


Regards

Nigel Taylor

On 06/19/10 01:09, Toan Nguyen wrote:
> Hi,
> 
>  
> 
> For those of you who have gotten openvas-libraries v3.0.5 to compile
> successfully, can you tell me what the pre-installation requirements
> are? I've read the INSTALL-README and it says:
> 
>  
> 
> * libglib >= 2.12
> 
>  * libgnutls >= 2.0
> 
>  * libpcap
> 
>  * libgpgme >= 1.1.2
> 
>  
> 
> I have met those requirements and I'm still failing during compilation
> time. The error is:
> 
>  
> 
> Linking C executable openvas-nasl
> 
> /home/openvas/apps/cmake/bin/cmake -E cmake_link_script
> CMakeFiles/openvas-nasl.dir/link.txt --verbose=1
> 
> /usr/bin/gcc   -Wall -D_FILE_OFFSET_BITS=64 -DLARGEFILE_SOURCE=1 -g
> -Wall  -L/home/openvas/apps/glib2/lib -lglib-2.0
> CMakeFiles/openvas-nasl.dir/nasl.c.o  -o openvas-nasl -rdynamic
> libopenvas_nasl.a ../base/libopenvas_base.so
../misc/libopenvas_misc.so
> ../hg/libopenvas_hg.so -L/home/openvas/apps/glib2/lib -lglib-2.0
> -lgcrypt -lgpgme -lgpg-error -lgnutls -lpcap -lresolv -lglib-2.0
> -lgcrypt -lgpgme -lgpg-error -lgnutls -lpcap
> -Wl,-rpath,../base:../misc:../hg:
> 
> /usr/local/lib/libgpgme.so: undefined reference to
> `gpg_err_code_from_syserror'
> 
> collect2: ld returned 1 exit status
> 
> make[3]: *** [openvas-nasl] Error 1
> 
> make[3]: Leaving directory
> `/home/openvas-3.0.2/src/openvas-libraries-3.0.5/nasl'
> 
>  
> 
>  
> 
> I've compiled the latest of the required dependencies besides libpcap.
> My versions are:
> 
> libglib = 2-24.1
> 
> libgnutls = 2.8.6
> 
> libpcap = 0.8.3
> 
> gpgme = 1.3.0
> 
>  
> 
>  
> 
> Is there another dependency that the configure script is not catching?
> Can I just omit nasl? I really do not care if it's included. I tried
> omitting it during configure time by passing "-without-nasl" but that
> didn't do anything. I'm running on:
> 
> Redhat Enterprise Linux ES release 4
> 
> 64bit arch
> 
>  
> 
> Thanks. Much appreciated.
> 
> 
> 
> _______________________________________________
> Openvas-discuss mailing list
> Openvas-discuss at wald.intevation.org
> http://lists.wald.intevation.org/mailman/listinfo/openvas-discuss



More information about the Openvas-discuss mailing list