[Openvas-discuss] openvas 4.0 on centos 5.5 / issues

Alicia Smith asmith at neospire.net
Fri Mar 18 17:02:32 CET 2011


I had to compile the latest version of sqlite3 and install it using
--prefix=/opt/slqite

Then I configured it to load in my ld.so.conf.d

 

Have you done that?

 

But when I rebuild or update my db, I have to have openvasmd shut down (
/etc/init.d/openvas-manager stop)

And the manager has to be updated after every sync in this manner.

 

 

 

 

From: Erik van Dam [mailto:erik at fortytwo.nl] 
Sent: Friday, March 18, 2011 10:58 AM
To: Alicia Smith
Cc: openvas-discuss at wald.intevation.org
Subject: Re: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues

 

Hi Alicia,

Thanks for your reply.

I tried that:

[root at openvas ~]# cat /dev/null > /var/log/openvas/openvasmd.log 
[root at openvas ~]# openvasmd --rebuild (it finishes)
[root at openvas ~]# cat /var/log/openvas/openvasmd.log 
md   main:WARNING:2011-03-18 15h53.42 utc :1649: sql: sqlite3_step
failed: database table is locked

md   main:CRITICAL:2011-03-18 15h53.42 utc :1649: handle_sigabrt: abort

I can't stand this, i'm running an fresh Centos 5.5, following the
guidelines.

On 03/18/2011 04:12 PM, Alicia Smith wrote: 

I'm sorry I said that wrong - 

shut down the openvasmd and run openvasmd -rebuild

restart it then try your sync and then you'll have to run openvasmd
-update again (with the manager stopped)

 

From: openvas-discuss-bounces at wald.intevation.org
[mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of Alicia
Smith
Sent: Friday, March 18, 2011 10:10 AM
To: Erik van Dam; openvas-discuss at wald.intevation.org
Subject: Re: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues

 

Shutdown openvasmd and run the nvt-sync.

That is what worked for me.

 

 

 

From: openvas-discuss-bounces at wald.intevation.org
[mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of Erik
van Dam
Sent: Friday, March 18, 2011 9:36 AM
To: openvas-discuss at wald.intevation.org
Subject: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues

 

Hi all,

I tried to install openvas 4.0 on centos 5.5 following this:

http://www.openvas.org/install-packages.html#openvas4_centos_atomic




Step 1: Configure Atomicorp Repository
(as user root, only once)

wget -q -O - http://www.atomicorp.com/installers/atomic |sh

Step 2: Quick-Install OpenVAS
(as user root, only once)

yum install openvas
openvas-nvt-sync-cron
openvas-adduser

Step 3: Quick-Start OpenVAS

( nothing to do, all is up and running directly after installation )

Step 4: Log into OpenVAS with user created in the step 2

 

I did this but openvasmd isn't willing to start:

md   main:   INFO:2011-03-18 14h29.11 utc :1565:    Updating NVT cache.
md   main:WARNING:2011-03-18 14h35.00 utc :1565: sql: sqlite3_step
failed: database table is locked
md   main:CRITICAL:2011-03-18 14h35.00 utc :1565: handle_sigabrt: abort


Now i'm intrested as this is an fresh install (kickstarted it) of Centos
5.5 who wrote this howto and did this got tested? On what Centos version
should this work out-of-the-box whit the above commands?

Thanks.




-- 
Met vriendelijke groet,
Erik van Dam
RedBee / FortyTwo






-- 
Met vriendelijke groet,
Erik van Dam
RedBee / FortyTwo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20110318/ee05b1a9/attachment.html>


More information about the Openvas-discuss mailing list