[Openvas-discuss] openvas 4.0 on centos 5.5 / issues

Dan The Man blammy8 at yahoo.com
Fri Mar 18 17:19:50 CET 2011


I'm having issues with the latest CentOS and Red Hat packages, but had 
everything working with the beta 4.0 version. Here's something I had to do to 
get the beta version working:

1. CentOS 5.5 and RHEL 5.5 have a version of sqlite that OpenVAS does not like. 
It needs a newer version. The version that comes with both is 3.3.6. One needs 
to install 3.7.5.

2. I download the tarball for sqlite, and since I did not want to interfere with 
the install sqlite version, I did ./configure --prefix=/opt/sqlite. I did 
make;make install and all was well.

3. I think what's important to OpenVAS is the libraries in /opt/sqlite/lib, so I 
added a file /etc/ld.so.conf.d/sqlite.conf that has the following line in it: 
/opt/sqlite/lib/libsqlite3.so.0

I'm now working on a fix for the latest packages.

-Dan




________________________________
From: Alicia Smith <asmith at neospire.net>
To: Erik van Dam <erik at fortytwo.nl>; openvas-discuss at wald.intevation.org
Sent: Fri, March 18, 2011 10:09:34 AM
Subject: Re: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues


Shutdown openvasmd and run the nvt-sync.
That is what worked for me.
 
 
 
From:openvas-discuss-bounces at wald.intevation.org 
[mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of Erik van Dam
Sent: Friday, March 18, 2011 9:36 AM
To: openvas-discuss at wald.intevation.org
Subject: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues
 
Hi all,

I tried to install openvas 4.0 on centos 5.5 following this:

http://www.openvas.org/install-packages.html#openvas4_centos_atomic



Step 1: Configure Atomicorp Repository
(as user root, only once)
wget -q -O - http://www.atomicorp.com/installers/atomic |sh
Step 2: Quick-Install OpenVAS
(as user root, only once)
yum install openvas
openvas-nvt-sync-cron
openvas-adduser
Step 3: Quick-Start OpenVAS
( nothing to do, all is up and running directly after installation )
Step 4: Log into OpenVAS with user created in the step 2
 
I did this but openvasmd isn't willing to start:

md   main:   INFO:2011-03-18 14h29.11 utc :1565:    Updating NVT cache.
md   main:WARNING:2011-03-18 14h35.00 utc :1565: sql: sqlite3_step failed: 
database table is locked
md   main:CRITICAL:2011-03-18 14h35.00 utc :1565: handle_sigabrt: abort


Now i'm intrested as this is an fresh install (kickstarted it) of Centos 5.5 who 
wrote this howto and did this got tested? On what Centos version should this 
work out-of-the-box whit the above commands?

Thanks.



-- 
Met vriendelijke groet,
Erik van Dam
RedBee / FortyTwo


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20110318/59e826b1/attachment.html>


More information about the Openvas-discuss mailing list