[Openvas-discuss] openvas 4.0 on centos 5.5 / issues

Dan The Man blammy8 at yahoo.com
Tue Mar 22 15:52:37 CET 2011


I did a fresh install with CentOS 5.5, installed latest and greatest sqlite3, 
did everything suggested on this list, but still when logged into gsad and 
clicking on "NVT Feed",  I receive an error:

Internal error: get_feed_oap:765

And openvasad.log says:

ad  admin:UNKNOWN:2011-03-22 09h49.18 CDT:6758: file 
/builddir/build/BUILD/openvas-administrator-1.1.1/src/admin.c: line 921 
(openvas_get_sync_script_description): assertion failed: (*description)

Should I file a bug report?

-Dan




________________________________
From: Alicia Smith <asmith at neospire.net>
To: Alicia Smith <asmith at neospire.net>; Erik van Dam <erik at fortytwo.nl>; 
openvas-discuss at wald.intevation.org
Sent: Fri, March 18, 2011 10:12:40 AM
Subject: Re: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues


I’m sorry I said that wrong – 
shut down the openvasmd and run openvasmd –rebuild
restart it then try your sync and then you’ll have to run openvasmd –update 
again (with the manager stopped)
 
From:openvas-discuss-bounces at wald.intevation.org 
[mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of Alicia Smith
Sent: Friday, March 18, 2011 10:10 AM
To: Erik van Dam; openvas-discuss at wald.intevation.org
Subject: Re: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues
 
Shutdown openvasmd and run the nvt-sync.
That is what worked for me.
 
 
 
From:openvas-discuss-bounces at wald.intevation.org 
[mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of Erik van Dam
Sent: Friday, March 18, 2011 9:36 AM
To: openvas-discuss at wald.intevation.org
Subject: [Openvas-discuss] openvas 4.0 on centos 5.5 / issues
 
Hi all,

I tried to install openvas 4.0 on centos 5.5 following this:

http://www.openvas.org/install-packages.html#openvas4_centos_atomic


Step 1: Configure Atomicorp Repository
(as user root, only once)
wget -q -O - http://www.atomicorp.com/installers/atomic |sh
Step 2: Quick-Install OpenVAS
(as user root, only once)
yum install openvas
openvas-nvt-sync-cron
openvas-adduser
Step 3: Quick-Start OpenVAS
( nothing to do, all is up and running directly after installation )
Step 4: Log into OpenVAS with user created in the step 2
 
I did this but openvasmd isn't willing to start:

md   main:   INFO:2011-03-18 14h29.11 utc :1565:    Updating NVT cache.
md   main:WARNING:2011-03-18 14h35.00 utc :1565: sql: sqlite3_step failed: 
database table is locked
md   main:CRITICAL:2011-03-18 14h35.00 utc :1565: handle_sigabrt: abort


Now i'm intrested as this is an fresh install (kickstarted it) of Centos 5.5 who 
wrote this howto and did this got tested? On what Centos version should this 
work out-of-the-box whit the above commands?

Thanks.


-- 
Met vriendelijke groet,
Erik van Dam
RedBee / FortyTwo


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20110322/35cd1ec7/attachment.html>


More information about the Openvas-discuss mailing list