[Openvas-discuss] GSA still not working

Juan José Pavlik Salles jjpavlik at gmail.com
Tue Nov 29 16:08:18 CET 2011


Ryan you saved me!! That was the problem, i hadn't install libgnutls-dev
nor libgcrypt-dev. I installed them and recompiled libmicrohttpd and now it
works great!!! Thanks!

One last thing... every time i perform a system update i should recompile
this library, right?

El 29 de noviembre de 2011 11:39, Ryan Schulze <security at dopefish.de>escribió:

>  Hi Juan,
>
> ssl is enabled by default *if* configure finds the files it needs. Can you
> check if the packages libgnutls-dev and libgcrypt-dev are installed?
> ./configure should spit out something like this at the end:
>
> configure: Configuration Summary:
>   Operating System:  linux-gnu
>   libgcrypt:         yes
>   libcurl (testing): yes
>   Target directory:  /usr/local
>   Messages:          yes
>   HTTP Authentic.:   yes
>   Postproc:          yes
>   HTTPS support:     yes
>
> configure: HTTPS subsystem configuration:
>   License         :  LGPL only
>
>
>
> On 11/29/2011 6:45 AM, Juan José Pavlik Salles wrote:
>
> I'm sorry.. i am using Ubuntu 10.04.3 LTS.
>
> El 29 de noviembre de 2011 09:18, Juan José Pavlik Salles <
> jjpavlik at gmail.com> escribió:
>
>> I didn't set any particular flag during compilation, i read the README
>> file and didn't find anything about it. It just says how to disable https
>> to save some space. Any ideas about howto turn ssl support on?
>>
>> El 29 de noviembre de 2011 09:11, --[ UxBoD ]-- <uxbod at splatnix.net>escribió:
>>
>>  Did you compile libmicrohttpd with SSL support ?
>>> --
>>> Thanks, Phil
>>>
>>> ------------------------------
>>>
>>>  Hi, a couple of weeks ago GSA stopped working, it consumes enourmes
>>> ammounts of cpu and the web ui doesn't load at all. I read this is caused
>>> by a compatibility issue with the newer versions of libmicrohttpd library,
>>> so i followed the steps to compile the older version libmicrohttpd-0.9.15.
>>> After compilation, without errors, i got libmicrohttpd.so.10.13.0, so i
>>> copied it to /usr/lib and changed the symbolic:
>>>
>>>  lrwxrwxrwx 1 root root     24 2011-11-29 08:54 libmicrohttpd.so.10 ->
>>> libmicrohttpd.so.10.13.0
>>> -rw-r--r-- 1 root root 206176 2011-11-29 08:47 libmicrohttpd.so.10.13.0
>>> -rw-r--r-- 1 root root  72440 2011-11-27 11:06 libmicrohttpd.so.10.14.0
>>> -rw-r--r-- 1 root root  72440 2011-11-29 08:49
>>> libmicrohttpd.so.10.14.0_bak
>>>
>>>  Then i started GSA and this showed up:
>>>
>>>  root at openvas:/usr/lib# /etc/init.d/greenbone-security-assistant start
>>> Starting Greenbone Security Assistant: MHD HTTPS option 8 passed to MHD
>>> compiled without HTTPS support
>>> ERROR.
>>>
>>>  GSA doesn't work at all... is there another workaround???
>>>
>>>  --
>>> Pavlik Juan José
>>>
>>>  _______________________________________________
>>> Openvas-discuss mailing list
>>> Openvas-discuss at wald.intevation.org
>>> http://lists.wald.intevation.org/mailman/listinfo/openvas-discuss
>>>
>>>
>>>
>>
>>
>>  --
>> Pavlik Juan José
>>
>
>
>
>  --
> Pavlik Juan José
>
>
> _______________________________________________
> Openvas-discuss mailing listOpenvas-discuss at wald.intevation.orghttp://lists.wald.intevation.org/mailman/listinfo/openvas-discuss
>
>
>
>


-- 
Pavlik Juan José
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20111129/a7207220/attachment.html>


More information about the Openvas-discuss mailing list