[Openvas-discuss] gsad won't start - MHD HTTPS problem

Steve Fluegel steve at fluegel.com
Mon Sep 19 15:27:34 CEST 2011


Michael,

Thank you very much. That works (I don't need HTTPS since I'm only accessing it as localhost). I was using stock Centos5 and Openvas installed from the atomicorp repository. Seems weird that centos would ship it that way.

I also tried installing on Centos6 and that worked fine.

Thanks again,

Steve

-----Original Message-----
From: openvas-discuss-bounces at wald.intevation.org [mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of Michael Wiegand
Sent: Monday, September 19, 2011 1:25 AM
To: openvas-discuss at wald.intevation.org
Subject: Re: [Openvas-discuss] gsad won't start - MHD HTTPS problem

* Steve Fluegel [18. Sep 2011]:
>    I’m trying to install openvas 4 on Centos 5 (32-bit). Everything seems to
>    go fine, but the gsad service won’t start. It gives this message:
> 
>     
> 
>    Starting greenbone-security-assistant: MHD HTTPS option 8 passed to MHD
>    compiled without HTTPS support

Apparently your distribution does not ship libmicrohttpd with HTTPS
support. If you want to use HTTPS, you can ask the maintainer of the
libmicrohttpd you are using for a version which supports it or build
libmicrohttpd yourself.

If you don't need HTTPS right now, you can launch gsad with the
"--http-only" parameter to use HTTP instead.

Regards,

Michael

-- 
Michael Wiegand |  Greenbone Networks GmbH  |  http://www.greenbone.net/
Neuer Graben 17, 49074 Osnabrück, Germany | AG Osnabrück, HR B 202460
Executive Directors: Lukas Grunwald, Dr. Jan-Oliver Wagner

_______________________________________________
Openvas-discuss mailing list
Openvas-discuss at wald.intevation.org
http://lists.wald.intevation.org/mailman/listinfo/openvas-discuss




More information about the Openvas-discuss mailing list