[Openvas-discuss] scan job stopped at 1%

Patrice Vallmajo patrice at papilia.com
Mon Aug 20 12:58:28 CEST 2012


I have the same issues and couldn't figure it out neither. I'm running
centOS too (CentOS release 5.8 (Final)) and I have same symptoms of openVAS
5 (installed form atomic using yum) that seems correct BUT scanned stay
stuck at 1%.

I have the same logs on failed "push" in *openvasmd.log*
*lib  serv:WARNING:2012-08-10 00h13.56 UTC:13668:    Failed to gnutls_bye:
Error in the push function.
==> /var/log/openvas/openvasmd.log <==
md   main:WARNING:2012-08-10 00h07.48 UTC:11188: read_from_server: failed
to read from server: A TLS packet with unexpected length was received.*
*
*
*Even disabling the firewall completely doesn't make them go away. BUT I
don't think (though I could be wrong) this is the source of my issue (I
don't have the other *Broken pipe warnings Klauss reported, could be my log
setting though).

Coz I have also a segmentation fault, so I think it's "simply" a crash in
the scanning thread
*==> /var/log/openvas/openvassd.log <==
[Fri Aug 10 00:07:45 2012][11187] SIGSEGV occured ! *
*
*
Coz I have also a segmentation fault, so I think it's "simply" a crash in
the scanning
*I've done some digging and found post that seems related with a fix
revolving around a** libmicrohttpd issue but trying the workaround in*
*
http://lists.wald.intevation.org/pipermail/openvas-discuss/2011-November/003613.htm<http://lists.wald.intevation.org/pipermail/openvas-discuss/2011-November/003613.html>
l*
http://osdir.com/ml/openvas-security-network/2012-05/msg00067.html
*
http://nachum234.no-ip.org/security/openvas/101-openvas-installation-on-ubuntu-10-04/
*
*didn't solve the issue for me.*
*I see some more recent posts that seems related (would the **libmicrohttpd
track be the right one)*
http://lists.wald.intevation.org/pipermail/openvas-discuss/2012-May/004213.html
http://seclists.org/openvas/2012/q3/81

There is no fix available in bin distrib on atomic (that I could see), it
seems options could be:
- to wait to a new release, though I'd like to complete my openvas
implementation by end of September so may not be able to wait further, I
just subscribed to the announcement mailing list, so I'm not sure yet of
the release plans
- to compile the sources, though I'd like to keep it last as for admin
efficiency I'm trying to avoid on prod non managed installs
- to downgrade to openvas 4, but I don't seem to be able to fin the centOS
bins for it, or a tutorial to do it properly.

I'll post if I'm progressing there in this thread, if I miss a
solution/option, please let me know (and bear with me for missing it).

Best,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20120820/9e12a8ae/attachment.html>


More information about the Openvas-discuss mailing list