[Openvas-discuss] Plugins reload

Derek Wuelfrath dwuelfrath at inverse.ca
Thu Feb 2 19:06:04 CET 2012


The way i'm starting a new task is either by the web gui or the omp 
command line.
Using ps, I see that there's a openvassd daemon waiting for connection 
and when i start a new task, there's a new process forked from that one 
serving 127.0.0.1
So no i'm not restarting openvassd each time.

I also noted that even if a restart a already done scan task, it takes 
long due to the plugins reload...
I scan task with a config of only one plugin can takes up to 10 minutes 
to finish...

On 2/2/12 13:34 , Matthew Mundell wrote:
> Are you restarting openvassd every time?  That's when it loads the NVTs and
> takes time.  Even if you create a new task every time, you can still use
> the same running set of OpenVAS daemons.
>
> --
> Greenbone Networks GmbH
> Neuer Graben 17, 49074 Osnabrueck, Germany | AG Osnabrueck, HR B 202460
> Executive Directors: Lukas Grunwald, Dr. Jan-Oliver Wagner

-- 
Derek Wuelfrath
dwuelfrath at inverse.ca <mailto:dwuelfrath at inverse.ca> :: +1.514.447.4918 
x110 :: www.inverse.ca <http://www.inverse.ca>
Inverse inc. :: Leaders behind SOGo (www.sogo.nu <http://www.sogo.nu>) 
and PacketFence (www.packetfence.org <http://www.packetfence.org>)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20120202/b63fb624/attachment.html>


More information about the Openvas-discuss mailing list