[Openvas-discuss] Install Error Message OpenVAS-5 using Fedora 15 on a Virtual Machine!

Jan Muhammad janmuhd at yahoo.com
Wed May 2 21:35:12 CEST 2012


Hi Group,

I am new to OpenVAS and struggling to install OpenVAS version5. Wonder is there any easy way to install/configure OpenVAS components. I am testing OpenVAS on a Fedora Core 15 Virtual Machine, host is based on Windows 7.

I tried to download source from (http://openvas.org/install-source.html). For each of component in the relevant directory when I read through the INSTALL instructions, there are various dependencies. I installed dependencies using Yum in one terminal and when I run the command:
# cmake .

I get long list of missing dependencies (but I already installed them, wonder how to specify the path as they were installed via Yum). Packages such as libxml, libxslt, libmicrohttpd are installed. For example when I check with rpm -qa command:
# rpm -qa libxml
libxml-1.8.17-27.fc15.i686


# rpm -qa libmicrohttpd
libmicrohttpd-0.9.6-2.fc15.i686



Below is the Error message:

 
Thanks in Advance for help!


-Jan 


=============================================================
root at localhost greenbone-security-assistant-3.0.1]# cmake -DCMAKE_INSTALL_PREFIX=/usr/share/mime/text
-- Configuring greenbone-security-assistant...
-- The C compiler identification is unknown
CMake Error: your C compiler: "CMAKE_C_COMPILER-NOTFOUND" was not found.   Please set CMAKE_C_COMPILER to a valid compiler path or name.
-- Looking for pkg-config... /usr/bin/pkg-config
-- checking for module 'libmicrohttpd>=0.4.2'
--   package 'libmicrohttpd>=0.4.2' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:266 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
  CMakeLists.txt:82 (pkg_check_modules)


-- checking for module 'libxml-2.0'
--   package 'libxml-2.0' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:266 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
  CMakeLists.txt:83 (pkg_check_modules)


-- checking for module 'libexslt'
--   package 'libexslt' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:266 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
  CMakeLists.txt:86 (pkg_check_modules)


-- checking for module 'libopenvas>=5.0.0'
--   package 'libopenvas>=5.0.0' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:266 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
  CMakeLists.txt:87 (pkg_check_modules)


-- checking for module 'libxslt'
--   package 'libxslt' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:266 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
  CMakeLists.txt:88 (pkg_check_modules)


Package libmicrohttpd was not found in the pkg-config search path.
Perhaps you should add the directory containing `libmicrohttpd.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libmicrohttpd' found
Package libmicrohttpd was not found in the pkg-config search path.
Perhaps you should add the directory containing `libmicrohttpd.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libmicrohttpd' found
Package libxml-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxml-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxml-2.0' found
Package libxml-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxml-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxml-2.0' found
Package libexslt was not found in the pkg-config search path.
Perhaps you should add the directory containing `libexslt.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libexslt' found
Package libexslt was not found in the pkg-config search path.
Perhaps you should add the directory containing `libexslt.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libexslt' found
Package libxslt was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxslt.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxslt' found
Package libxslt was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxslt.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxslt' found
CMake Error at CMakeLists.txt:149 (message):
  One or more required libraries was not found (see message above), please
  install the missing libraries and run cmake again.

-- Configuring incomplete, errors occurred!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20120502/5ac0cdfc/attachment.html>


More information about the Openvas-discuss mailing list