[Openvas-discuss] Compiling openvas-libraries-5.0.1 with libssh 0.5.2 on Ubuntu 12.04

Peter Thomas hackertarget.admin at gmail.com
Mon May 14 07:43:32 CEST 2012


Hello,

I am having a similar issue while spinning up OpenVAS 5 for some testing.

Compilation of openvas-libraries under Ubuntu 12.04 fails with:

* snip *
libopenvas_nasl.a(nasl_ssh.c.o): In function `nasl_ssh_exec':
/home/testuser/openvas-libraries-5.0.1/nasl/nasl_ssh.c:247: undefined
reference to `ssh_new'
/home/testuser/openvas-libraries-5.0.1/nasl/nasl_ssh.c:249: undefined
reference to `ssh_options_set'
* snip *

Just to add some more information; I have tried downgrading from the
Ubuntu release version libssh 0.5.2 to an older Ubuntu release
0.4.5-3ubuntu1. After doing this the same error occurs.

I did manage to compile the libraries, but it required removing libssh
from the system; presumably removing ssh from testing.


Regards,

Peter
--------------------------------------------------
Security Scanning Tools On-line
Web: http://hackertarget.com/
--------------------------------------------------


----------------------------------------------------------------------------------------------------
Hi,

I'm miserably failing at compiling the openvas-libraries and hope
someone on the list can give me a pointer in the right direction. I
downloaded the sourcecode, installed the build tools, downloaded,
patched and compiled wmiclient, and cmake seems happy with everything,
but make stumbles horribly over libssh (according to apt, version 0.5.2
of libssh and libssh-dev is installed). Added the output of cmake and
make below.

I'm not new to compiling software from source, but I can't seem to fix
this one (aside from compilng it without libssh). Is this another one of
those Ubuntu specific problems? Has anyone ran into similar problems
with a different OS (or had no problems compiling with libssh on other OS)?

Thanks,
Ryan



root at testarea # export
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/package/lib/pkgconfig
root at testarea # cmake -DCMAKE_INSTALL_PREFIX=/usr/local/package/ .
-- Configuring the Libraries...
-- The C compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Install prefix: /usr/local/package
-- checking for module 'gnutls>=2.2'
--   found gnutls, version 2.12.14
-- checking for module 'glib-2.0>=2.16'



More information about the Openvas-discuss mailing list