[Openvas-discuss] gsad - libmicrohttpd problems

Juan José Pavlik Salles jjpavlik at gmail.com
Thu May 17 04:12:09 CEST 2012


Miguel, you should check this
http://lists.wald.intevation.org/pipermail/openvas-discuss/2011-November/003613.html

2012/3/23 Miguel Lucero <miguel.lucero at gmail.com>

> I just loaded the latest OpenVAS on Ubuntu 11.10 and can not get gsad to
> work.
>
> Whenever I try to login using the web gui the gsad process starts using
> 99% cpu and login never succeeds. There are times when I cant even get the
> login page and the process begins to climb without showing me a login
> prompt. I tried searching for a solution and everything said it was a bug
> in libmicrohttpd but that was referring to an old version. I tried
> compiling an old version of libmicrohttpd (0.9.15) and it appeared to
> resolve it temporarily but the problem came back after I restarted the
> services. I attached to the process with strace but was not able to
> retrieve anything meaningful.
>
> I'm running the following:
>
> openvas 3.2.5-1
> openvas-manager 2.0.4-1
> openvas-cli 1.1.4-1
> openvas-administrator 1.1.2-1
> libmicrohttpd 0.9.19.1
> Ubuntu 11.10
>
> This only happens when running the gsad with SSL. If I run the service
> manually with --http-only, the application responds correctly and the
> process does not run away.
>
> Any help would be great... I am very interested in resolving this issue
> for other users. Thank you!
>
> Miguel
>
> _______________________________________________
> Openvas-discuss mailing list
> Openvas-discuss at wald.intevation.org
> http://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-discuss
>



-- 
Pavlik Juan José
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20120516/0b2cac96/attachment.html>


More information about the Openvas-discuss mailing list