[Openvas-discuss] Weird issue - GSA Login Failed - KALI distro

Winfried Neessen neessen at cleverbridge.com
Wed Feb 4 16:27:37 CET 2015


Hi, 

despite you say, the OpenVAS manager was on "error" all the time and everything worked though, 
the OpenVAS is mandatory and nothing will actually work without it. It provides the OMP protocol 
which is used by the other OpenVAS services i. e. to authenticate the user (and a lot more stuff). 

Check the log of the OpenVAS manager to find out why it's failing/in error state. If you need help 
with that, provide the log to this list. 

Winni 

> From: "Randy Dover" <rdover at cscbank.com>
> To: "openvas-discuss" <openvas-discuss at wald.intevation.org>
> Sent: Wednesday, February 4, 2015 4:14:08 PM
> Subject: [Openvas-discuss] Weird issue - GSA Login Failed - KALI distro

> I installed Kali-Linux on a VM server last year. Got OpenVas up and running. Set
> up some scheduled scans. Got those scans for two-three weeks. Everything was
> fine.

> Was able to login and check everything on OpenVas using Greenbone Security
> Assistant for 2-3 months.

> The month of January was pretty crazy for us. I didn’t check it during the
> month.

> I went to login to GSA on Monday and couldn’t – kept getting “Login failed” I
> had the account documented, so I know I was typing credentials correct. I even
> went through the process of adding another user, using command line. The new
> user “took”, but it too gave me a Login failed.

> I have done a feed sync, it was successful. (I’ve done feed sync both “manually”
> from CLI and from menu.)

> I ran “openvas-check-setup” from CLI and got the response “It seems like your
> OpenVAS-6 installation is OK.”

> I ran “openvas-check-setup” from KALI Applications > Kali Linux > Vulnerability
> Analysis > OpenVAS > openvas start and got:

> Step 1. Checking OpenVAS Scanner: present in version3.4.0, scanner CA is
> present…

> OK: NVT collection …contains 37863 NVTs

> Warning: Signature checking of NVTs is not enabled in OpenVAS Scanner (how do I
> enable this after I get GSA running)

> OK: NVT cache…contains 39023 files for 37863 NVTs

> Step 2. OK OpenVAS Manager is present in version 4.0.4

> OK OpenVAS Manger client is present…

> OK OpenVAS Manager database is found…

> OK: Access rights…are correct

> OK: sqlite3 found, extended…enabled

> OK: OpenVAS Manager database…74

> OK: OpenVAS Manager expects…74

> OK: Database schema is up to date

> OK: OpenVAS SCAP found…

> OK: OpenVAS Cert found…

> OK: xsltproc found

> Step 3. Checking OpenVAS Administrator…

> OK: OpenVAS Administrator…ver 1.3.2

> OK: At least one user exists.

> OK: At least one admin user exists

> Warning: Your password policy is empty SUGGEST:

> Step 4. Checking GSA…

> OK: GSA…ver 4.0.0

> Step 5. Checking CLI…

> OK: CLI ver 1.2.0

> Step 6. Checking GSD…

> OK: GSD ver 1.2.2

> Step 7. Checking if OpenVAS services…

> OK: netstat found, extended enabled

> OK: OpenVAS scanner running, listening only on local interface

> OK: Openvas Scanner is listening on port 9391

> ERROR: OpenVAS Manager is NOT running!

> OK: OpenVAS Administrator is running and listening only on local interface

> OK: OpenVAS Administrator is listening on port 9393

> WARNING: FSA is running and listening only on the local…

> OK: GSA is listening on port 9392

> ERROR: Your OpenVAS-6 installation is not yet complete!

> I started the OpenVas services using the KALI Applications > Kali Linux >
> Vulnerability Analysis > OpenVAS > openvas start (which runs
> openvas-check-setup 2.2.3), got the following:

> Starting OpenVas Services

> Starting Greenbone Security Assistant: gsad.

> Starting OpenVAS Scanner: openvassd

> Starting OpenVAS Administrator: openvasad

> Starting OpenVAS Manager: ERROR (This has always been error. The install has
> worked fine even with it in error mode.)

> I have searched and searched on the web, no luck.
> I saw one user say it was “ Never mind. PEBCAK. Stupid me. It was the firewall
> blocking access to loopback… ” One, I don’t know how the firewall would’ve
> gotten turned on, two, don’t know how to check that on the KALI distro.
> I even restored the VM to a few weeks ago, and got the same error. Even tried
> some of the fixes, such as adding a new user.
> Why can’t I login to the Webpage on the KALI machine itself? I’m using the
> IceWeasel browser, going to https://127.0.0.1:9392 , just like I always did.
> Sometimes when I try to login, I get “Login failed. OMP service is down”
> I used this installation for at least three months and never had a login problem
> (unless I fat-fingered the password!)
> I’ve done everything I know to try and tried several things I found on the web.
> I can’t login at all. I know the username and password. I created a new user
> (admin level) and can’t login with it either.

> Randy Dover
> Vice President / Information Technology Officer
> Cornerstone Community Bank
> 6401 Lee Highway, Suite 119
> Chattanooga, TN 37421
> Telephone: 423-385-3010
> rdover at cscbank.com
> This email is intended for its designated recipients. The information, and
> attachments, contained in this email may be considered private and/or
> confidential. If the transmission is received in error, delete messages(s) from
> your system and notify the sender. You may not, directly or indirectly, use,
> disclose or distribute any part of this email.
> _______________________________________________
> Openvas-discuss mailing list
> Openvas-discuss at wald.intevation.org
> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20150204/15c206d0/attachment.html>


More information about the Openvas-discuss mailing list