[Openvas-discuss] Problems logging in via ssh through slave

Todd Courtnage todd at chaordix.com
Fri Feb 6 21:50:40 CET 2015


Hi.

I'm having a problem that I think is a bug, but would like to run it past
the community, in case I'm missing something.

I want to scan a target that is in a private network. The private network
is not accessible by my OpenVAS "master" server.

I've setup an OpenVAS slave machine to be the intermediary and the master
is successfully talking to the slave, and the slave is successfully
connecting to the target, via ssh, but not on the port I specified in the
target configuration. It's using the default ssh port 22.

In the target configuration, I've set the "SSH Credential" to the
appropriate user and set the ssh port (2200), but when I run the scan, the
slave machine tries to connect up to ssh on port 22, not 2200. (If I
temporarily change my sshd configuration on the target to accept
connections on port 22, the slave successfully connects up with the ssh
username I specified in the configuration).

It seems that slaves do not pick up the ssh port specified when setting up
the target configuration.

Incidentally, if I run the same scan on my localhost target (not using the
slave at all), it does use port 2200, which is why I think it seems to be a
slave-specific issue.

-- 
*Todd Courtnage*
Director of Cloud Computing

Chaordix – Crowd Intelligence

email: todd at chaordix.com
office: +1.403.263.2655
toll free: +1.866.263.7775
mob: + 1.403.975.1591

http://www.chaordix.com


Follow us on twitter: http://twitter.com/chaordix
Our blog: http://www.chaordix.com/blog/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20150206/46061eea/attachment.html>


More information about the Openvas-discuss mailing list