[Openvas-discuss] OpenVAS / gsad hang

Islam Moursy Islam.Moursy at bibalex.org
Thu Jul 9 14:07:48 CEST 2015



I found the below errors on redis server log ,
“
[2738] 09 Jul 12:29:39 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
“


I followed up what the error advised , and restarted the machine  I got new behavior in OpenVAS , which is when starting the task , it ends quickly and has a severity of error , again nothing abnormal in OpenVAS logs ,
You can check the screen cap for the task status
http://i.imgur.com/5JWA7ei.jpg




BR,
Islam Moursy

From: Islam Moursy
Sent: Thursday, July 9, 2015 11:06 AM
To: 'Eero Volotinen'
Subject: RE: [Openvas-discuss] OpenVAS / gsad hang

Open vas installed from packages ,
I use kali distro, Linux kali 3.18.0-kali3-amd64 #1 SMP Debian 3.18.6-1~kali2 (2015-03-02) x86_64 GNU/Linux
Versions are as below
root at kali:~# dpkg -l | grep '^ii'| egrep 'openvas*|greenbon*' |  awk '{print $2 "\t" $3}'
greenbone-security-assistant    6.0.1-0kali1
libopenvas8     8.0.1-0kali1
openvas 8.0
openvas-cli     1.4.0-0kali1
openvas-manager 6.0.1-0kali1
openvas-scanner 5.0.1-0kali1

BR,
Islam Moursy

From: Eero Volotinen [mailto:eero.volotinen at iki.fi]
Sent: Thursday, July 9, 2015 11:02 AM
To: Islam Moursy
Subject: Re: [Openvas-discuss] OpenVAS / gsad hang


What is version of openvas and what linux version, including distribution name you are using? Is openvas installed from packages or compiled from source?

Eero

to 9. heinäkuuta 2015 11.59 Islam Moursy <Islam.Moursy at bibalex.org<mailto:Islam.Moursy at bibalex.org>> kirjoitti:
When starting a task with omp (cli) the command does not ever return , and when issuing tasks status from another console the status of the task is stopped
Nothing shown on logs as well

BR,
Islam Moursy

From: eero.t.volotinen at gmail.com<mailto:eero.t.volotinen at gmail.com> [mailto:eero.t.volotinen at gmail.com<mailto:eero.t.volotinen at gmail.com>] On Behalf Of Eero Volotinen
Sent: Thursday, July 9, 2015 10:45 AM

To: Islam Moursy
Cc: openvas-discuss at wald.intevation.org<mailto:openvas-discuss at wald.intevation.org>
Subject: Re: [Openvas-discuss] OpenVAS / gsad hang

is it working with omp-cli? what omp (cli) says about task status?

--
Eero

2015-07-08 15:39 GMT+03:00 Islam Moursy <Islam.Moursy at bibalex.org<mailto:Islam.Moursy at bibalex.org>>:
The only error shown on openvassd.dump

“lib  kb_redis-CRITICAL **: get_redis_ctx: redis connection error: No such file or directory”
I made sure that gsad and openvasmd are running well , but still the same problem


BR,
Islam Moursy

From: eero.t.volotinen at gmail.com<mailto:eero.t.volotinen at gmail.com> [mailto:eero.t.volotinen at gmail.com<mailto:eero.t.volotinen at gmail.com>] On Behalf Of Eero Volotinen
Sent: Wednesday, July 8, 2015 2:21 PM
To: Islam Moursy
Cc: openvas-discuss at wald.intevation.org<mailto:openvas-discuss at wald.intevation.org>
Subject: Re: [Openvas-discuss] OpenVAS / gsad hang


Check out openvas logs?

Eero
8.7.2015 3.16 ip. "Islam Moursy" <Islam.Moursy at bibalex.org<mailto:Islam.Moursy at bibalex.org>> kirjoitti:


There was a task running for an unexpected long time, when I tried to stop the task , it succeeded however when initiated a rerun for the task , it seems as if gsad waiting forever for the web request to fullfill
No errors are shown on the logs
Pelase advise

BR,
Islam Moursy


_______________________________________________
Openvas-discuss mailing list
Openvas-discuss at wald.intevation.org<mailto:Openvas-discuss at wald.intevation.org>
https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20150709/9a73b7cb/attachment.html>


More information about the Openvas-discuss mailing list