[Openvas-discuss] Problem installing openvas 9 from Ubuntu packages

Ashok P Gowda ashokpgowda at hotmail.com
Thu Nov 5 11:19:39 CET 2015


Hi Eero,
Can you tell me why openvasmd listening on tcp6 ?
[root at VDLRHGL06-ITinternal ~]# netstat -tulpn | grep 9390tcp6       0      0 :::9390                 :::*                    LISTEN      70321/openvasmd ThanksAshok
Date: Thu, 5 Nov 2015 07:47:27 +0200
Subject: RE: [Openvas-discuss] Problem installing openvas 9 from Ubuntu packages
From: eero.volotinen at iki.fi
To: ashokpgowda at hotmail.com; openvas-discuss at wald.intevation.org

Well, you can use strace and similar tools to debug this issue.


Eero
5.11.2015 7.12 ap. "Ashok P Gowda" <ashokpgowda at hotmail.com> kirjoitti:



Hi Eero,
Thanks for quick reply, I tried as you said, but still same issue, is there any alternate ways to fix this?
Thanks Ashok

Date: Wed, 4 Nov 2015 15:05:32 +0200
Subject: RE: [Openvas-discuss] Problem installing openvas 9 from Ubuntu packages
From: eero.volotinen at iki.fi
To: openvas-discuss at wald.intevation.org; ashokpgowda at hotmail.com

And openvas-check-setup says that openvas manager is not running.
This.is usually fixed with systemctl restart openvas-manager.service 
Eero
4.11.2015 2.59 ip. "Eero Volotinen" <eero.volotinen at iki.fi> kirjoitti:
Well, logs says that some program is already using that port. Manager port?
Someone said that running openvas-nvt-sync might fix this issue.
Eero
4.11.2015 2.34 ip. "Ashok P Gowda" <ashokpgowda at hotmail.com> kirjoitti:



Hi Eero,
Please find see openvas-checkup error below,     ERROR: OpenVAS Manager is NOT running!        FIX: Start OpenVAS Manager (openvasmd).        WARNING: Greenbone Security Assistant is listening on port 9392 80, which is NOT the default port!        SUGGEST: Ensure Greenbone Security Assistant is listening on one of the following ports: 80, 443, 9392.
 ERROR: Your OpenVAS-8 installation is not yet complete!
Thanks Ashok 

From: ashokpgowda at hotmail.com
To: eero.volotinen at iki.fi
Subject: RE: [Openvas-discuss] Problem installing openvas 9 from Ubuntu packages
Date: Wed, 4 Nov 2015 18:01:14 +0530




Hi Eero,
Am getting below error, kindly help me to fix this,
md   main:WARNING:2015-11-04 11h34.05 utc:5302: Failed to bind manager socket: Address already in usemd   main:WARNING:2015-11-04 11h34.08 utc:5873: Failed to bind manager socket: Address already in usemd   main:WARNING:2015-11-04 11h34.10 utc:6579: Failed to bind manager socket: Address already in usemd   main:WARNING:2015-11-04 11h34.12 utc:7248: Failed to bind manager socket: Address already in usemd   main:WARNING:2015-11-04 11h34.15 utc:7975: Failed to bind manager socket: Address already in usemd   main:WARNING:2015-11-04 11h34.17 utc:8741: Failed to bind manager socket: Address already in uselib auth:   INFO:2015-11-04 12h11.48 utc:64219: Authentication configuration not found.lib auth:   INFO:2015-11-04 12h12.02 utc:64258: Authentication configuration not found.lib auth:   INFO:2015-11-04 12h12.47 utc:70083: Authentication configuration not found.md   main:WARNING:2015-11-04 12h12.55 utc:70117: Failed to bind manager socket: Address already in use
ThanksAshok
Date: Fri, 30 Oct 2015 12:22:19 +0200
From: eero.volotinen at iki.fi
To: steve.kuekes at physicianspharmacy.com
CC: openvas-discuss at wald.intevation.org
Subject: Re: [Openvas-discuss] Problem installing openvas 9 from Ubuntu	packages

Hi,
OpenVAS8 is latest stable, please install it on Centos 7 as UBuntu packages are really "poor" quality.
It's really simple to install on centos 7 ..
Just install Centos 7.0 or greater (I think that 7.1 is latest version)
Instructions:
https://atomicorp.com/forums/viewtopic.php?f=31&t=8047

"simplified version of installation":
1. step:
add atomic repo:
wget -q -O - http://www.atomicorp.com/installers/atomic | sh

2. step
install
yum -y install openvas
Then just check with openvas-check-setup --v8 that everything works. You might need to check redis configuration, but that is really simple
Have a fun.
br,--Eero
2015-10-28 16:31 GMT+02:00 Steve Kuekes <steve.kuekes at physicianspharmacy.com>:
I'm having a problem installing openvas 9 from Ubuntu packages on 14.04.  (I tried this for openvas 8 as well with the same results).



I've followed the directions in



https://launchpad.net/~mrazavi/+archive/ubuntu/openvas



and installed from packages.



When I do this step "sudo openvasmd --rebuild --progress"

I'm getting an error message in the openvasmd.log file and the rebuild fails with the message of "Rebuilding NVT cache... failed"



md   main:MESSAGE:2015-10-27 18h57.51 utc:22793:    OpenVAS Manager version 6.1+beta1 (DB revision 150)

lib  serv:WARNING:2015-10-27 18h57.52 utc:22794: Failed to shake hands with peer: A TLS packet with unexpected length was received.



I've tried googling to figure out the problem.  This is keeping me from completing the install.



Thanks in advance for any help.



Steve



-- 

Steve Kuekes

CTO

Physicians Pharmacy Alliance

118 MacKenan Drive, Suite 200

Cary, NC  27511

919-465-5801 direct

919-463-5555 main

919-463-5566 fax



steve.kuekes at physicianspharmacy.com



_______________________________________________

Openvas-discuss mailing list

Openvas-discuss at wald.intevation.org

https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-discuss




_______________________________________________
Openvas-discuss mailing list
Openvas-discuss at wald.intevation.org
https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-discuss 		 	   		   		 	   		  

 		 	   		  
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20151105/3a839842/attachment.html>


More information about the Openvas-discuss mailing list