[Openvas-discuss] Database Version Error (postgres migration)

Jan-Oliver Wagner Jan-Oliver.Wagner at greenbone.net
Wed Nov 9 15:51:19 CET 2016


Am Freitag, 15. Juli 2016, 09:53:29 schrieb prydzynski .:
> I am currently having an issue when attempting to use the
> 'openvas-migrate-to-postgres' script. The database version returned from
> the command "select value from meta where name = 'database_version';" is
> '146'. The bash script checks this and returns "Database version not
> supported" as the only versions supported are 133, 134, 135, and 136. Is
> there a workaround for people using version 146 (or anything in between) or
> can we not migrate to postgres?

in preparation of OpenVAS-9 we recently extended the migration part.
So, at least migration from 146 sqlite towards OpenVAS-9 should work.

fyi: 146 is OpenVAS-8. OpenVAS-9 will have 184.

-- 
Dr. Jan-Oliver Wagner |  +49-541-335084-0  |  http://www.greenbone.net/
Greenbone Networks GmbH, Neuer Graben 17, 49074 Osnabrück | AG Osnabrück, HR B 
202460
Geschäftsführer: Lukas Grunwald, Dr. Jan-Oliver Wagner



More information about the Openvas-discuss mailing list