[Openvas-discuss] INTERNAL ERROR IN GSA

Παναγιώτης Λεόντιος leontiosp at ath.forthnet.gr
Tue Oct 11 16:01:40 CEST 2016


·         OK, I started redis-server, but now, "redis /var/lib/redis/redis.sock> keys *" returns "(empty list or set)".

·         Nevertheless, I continued

·         Don’t understand “> 1) "OpenVAS.__GlobalDBIndex"”, so I skipped it

·         And finally "del OpenVAS.__GlobalDBIndex" returned "(integer) 0”

 

------------------------------------------------------------------------------

 

Dear Michael, Fabio,

 

The command "redis-cli -s /var/lib/redis/redis.sock" in " root at kali:/etc/openvas# " returns " Could not connect to Redis at /var/lib/redis/redis.sock: No such file or directory"

 

Panos

 

-----Original Message-----

From:  <mailto:Michael.Eissele at greenbone.net> Michael.Eissele at greenbone.net [ <mailto:Michael.Eissele at greenbone.net> mailto:Michael.Eissele at greenbone.net]

Sent: Tuesday, October 11, 2016 2:10 PM

To: Fábio Fernandes

Cc: Παναγιώτης Λεόντιος;  <mailto:openvas-discuss at wald.intevation.org> openvas-discuss at wald.intevation.org

Subject: Re: [Openvas-discuss] INTERNAL ERROR IN GSA

 

Dear Panos,

 

htop is a process viewer tool, you will probably have to install it (sorry i forgot to mention this): apt-get install htop But i suggest you hold back with htop and try the method of Fabio first- this could indeed be the source for the Problem you describe.

Please let us know afterwards.

 

Kind Regards, Michael.

 

 

 

On 11.10.2016 10:59, Fábio Fernandes wrote:

> If the task is blocked in requested try this:

> 

> Erase OpenVAS data in Redis.

> 

> root at kali:/etc/openvas# redis-cli -s /var/lib/redis/redis.sock

> 

> redis

> /var/lib/redis/redis.sock> keys *

> 1) "OpenVAS.__GlobalDBIndex"

> redis /var/lib/redis/redis.sock> del OpenVAS.__GlobalDBIndex

> (integer) 1

> 

> Fabio

> 

>> No dia 11/10/2016, às 09:52, Παναγιώτης Λεόντιος 

>> < <mailto:leontiosp at ath.forthnet.gr> leontiosp at ath.forthnet.gr> escreveu:

>> 

>> Dear Michael,

>> 

>> Following my last email below, I run a new task with everything left 

>> to default (Scan config: discovery) and it stuck to "Requested"; 

>> never continued to a percentage.

>> Of course, when requested the current report, it produced the known 

>> internal error :(

>> 

>> P.S. One more thing; when I run "openvas-start" in my command line 

>> before GSA, it produces an error saying that manager daemon cannot 

>> run.

>> After running "openvasmd" and then "openvas-start", everything is OK 

>> (checked by "openvas-check-setup" and "systemctl status 

>> openvas-manager.service").

>> 

>> Panagiotis Leontios

>> Business Engineer | Project Manager | Consultant BEng, DIC, MSc, MBA

>> 

>> M: +30 6977 976269

>> E:  <mailto:leontiosp at ath.forthnet.gr> leontiosp at ath.forthnet.gr

>> B: pleontios.wordpress.com [1]

>> L:  <http://www.linkedin.com/in/leontios> www.linkedin.com/in/leontios [2]

>> T: @pleontios

>> -----Original Message-----

>> From: Παναγιώτης Λεόντιος

>> [ <mailto:leontiosp at ath.forthnet.gr> mailto:leontiosp at ath.forthnet.gr]

>> Sent: Tuesday, October 11, 2016 11:17 AM

>> To: 'Michael.Eissele at greenbone.net'

>> Cc: 'openvas-discuss at wald.intevation.org'

>> Subject: RE: [Openvas-discuss] INTERNAL ERROR IN GSA

>> 

>> Dear Michael, thanks again for your response.

>> 

>> Actually, in the screenshot was the error message:

>> 

>> “INTERNAL ERROR: GET_REPORT:12102 (GSA 6.0.10) ...

>> Diagnostics: Failure to receive response from Manager Daemon"

>> 

>> The target IPs, Portlist, AliveCheck is set to default; Scan is set 

>> to Fast and Full. Actually, just created a new task with defaults; 

>> Only Fast and Full was set differently.

>> 

>> YES, I run it on Vbox (5.1.6) with default configuration as provided 

>> by official .ova file (kali-linux-i686) -ram 2048, 2 CPUs, etc.

>> 

>> (*) I don’t understand that htop thing though.

>> (*) I will try to run the task starting by " Full and Very Deep 

>> Ultimate scan configuration " according to your link and let you 

>> know.

>> (*) I have all the updates, dist-upgrades done, as well as openvas 

>> recent install, and check-setup resulted OK.

>> 

>> Panos

>> 

>> -----Original Message-----

>> From:  <mailto:Michael.Eissele at greenbone.net> Michael.Eissele at greenbone.net

>> [ <mailto:Michael.Eissele at greenbone.net> mailto:Michael.Eissele at greenbone.net]

>> Sent: Monday, October 10, 2016 7:01 PM

>> To: Παναγιώτης Λεόντιος

>> Cc:  <mailto:openvas-discuss at wald.intevation.org> openvas-discuss at wald.intevation.org

>> Subject: RE: [Openvas-discuss] INTERNAL ERROR IN GSA

>> 

>> Dear Panos,

>> 

>> i am sorry, but unfortunately i am unable to view your screenshots as 

>> something (probably on my side, limited environment) breaks them.

>> If they contain no further sensitive information, you could maybe 

>> upload them at an imagehoster (directupload.net [3] i.e.) and send me 

>> the link?

>> 

>> Just to be clear about that- could you maybe be affected by this

>> Problem:  <https://bugs.kali.org/view.php?id=3055> https://bugs.kali.org/view.php?id=3055 [4] ?

>> If yes, use a different Scanconfig (start minimalistic with 

>> "Discovery"

>> for example, then go with "Full and Fast").

>> 

>> In general, some more details about how you have setup your scan 

>> could be of help.

>> (i.e. how many target ip's are scanned, what Portlist is being used, 

>> what AliveCheck, Scanconfig, etc.).

>> 

>> Please also provide the following: a screenshot of htop, which has 

>> been filtered before to "openvas" (you can filter in htop by hitting 

>> the "F4"

>> key).

>> 

>> If you run this as a VirtualMachine, ensure that you have allocated 

>> enough hardware ressources to the vm.

>> 

>> Kind Regards,

>> Michael Eissele.

>> 

>> On 10.10.2016 17:05, Παναγιώτης Λεόντιος wrote:

>> Thank you Michael.

>> 

>> Yes, I have run "openvas-check-setup" script and it reported OK.

>> 

>> Also, please see below my current state of the problem:

>> 

>> Well, I have successfully completed an installation of Kali 32 in 

>> Vbox, installed openvas, checked its setup and run GSA.

>> 

>> When running my first task, it freezes in requested mode and 

>> additionally, when pressing on the bar to get a report the following

>> 

>> error message is produced

>> 

>> Thank you in advance.

>> 

>> P.S. I have installed kali 32 perfectly OK on a USB (in persistence 

>> mode), and also the demo in the same VB.

>> 

>> But this one……

>> 

>> -----Original Message-----

>> From:  <mailto:Michael.Eissele at greenbone.net> Michael.Eissele at greenbone.net

>> [ <mailto:Michael.Eissele at greenbone.net> mailto:Michael.Eissele at greenbone.net]

>> Sent: Monday, October 10, 2016 6:00 PM

>> To: Παναγιώτης Λεόντιος

>> Cc:  <mailto:openvas-discuss at wald.intevation.org> openvas-discuss at wald.intevation.org

>> Subject: RE: [Openvas-discuss] INTERNAL ERROR IN GSA

>> 

>> Dear Panos,

>> 

>> thank you for reaching back.

>> 

>> From what you have reported, it seems that your installation may be 

>> in an inconsistant state in general.

>> 

>> Is this the first time you run scans on this installation, or had 

>> this installation already been running for some time?

>> 

>> Nevertheless, we should go back and asure basic functionality as this 

>> seems messed up a bit.

>> 

>> Please visit:  <http://www.openvas.org/setup-and-start.html> http://www.openvas.org/setup-and-start.html [5] [1]

>> 

>> You will find the "openvas-check-setup" script. Please run this and 

>> follow possible occuring fixing advices.

>> 

>> We should only continue here if this script tells that everything is

>> 

>> ok, otherwise it won't make much sense.

>> 

>> Let us know after, thanks a lot.

>> 

>> Kind Regards,

>> 

>> Michael Eissele.

>> 

>> On 10.10.2016 13:06, Παναγιώτης Λεόντιος wrote:

>> 

>> And now I notice that the task does not move forward to a percentage;

>> 

>> it has stuck to “requested” state…

>> 

>> Sth is wrong with the manager daemon?

>> 

>> FROM: Παναγιώτης Λεόντιος

>> 

>> [ <mailto:leontiosp at ath.forthnet.gr> mailto:leontiosp at ath.forthnet.gr]

>> 

>> SENT: Monday, October 10, 2016 1:58 PM

>> 

>> TO: 'Michael.Eissele at greenbone.net'

>> 

>> SUBJECT: RE: [Openvas-discuss] INTERNAL ERROR IN GSA

>> 

>> I get this message again in a new task running (requested mode), when

>> 

>> trying to get the report.

>> 

>> Panos

>> 

>> -----Original Message-----

>> 

>> From:  <mailto:Michael.Eissele at greenbone.net> Michael.Eissele at greenbone.net

>> 

>> [ <mailto:Michael.Eissele at greenbone.net> mailto:Michael.Eissele at greenbone.net]

>> 

>> Sent: Monday, October 10, 2016 1:41 PM

>> 

>> To: Παναγιώτης Λεόντιος

>> 

>> Subject: RE: [Openvas-discuss] INTERNAL ERROR IN GSA

>> 

>> Dear Pano,

>> 

>> this may occur because the affected report is appearing in the list

>> 

>> that loads when selecting report view.

>> 

>> Please go the way over Taskview, from there on you can check through

>> 

>> the reports and limit the trouble causing source to atleast to one

>> 

>> task maybe.

>> 

>> Once you have figured out the name of that report, you could try (as

>> 

>> mentioned in the previous reply) and delete this report with an Admin

>> 

>> or Superadmin user.

>> 

>> If this doesn't work out, then let us know, we then have to remove 

>> the

>> 

>> report manually from the machine.

>> 

>> Kind Regards,

>> 

>> Michael Eissele.

>> 

>> On 10.10.2016 12:30, Παναγιώτης Λεόντιος wrote:

>> 

>> Dear Michael,

> 

>> 

> 

>>> 

> 

>> 

> 

>>> Thank you for responding.

> 

>> 

> 

>>> 

> 

>> 

> 

>>> Well, I get a similar error when even trying to go to Reports

> 

>> window!

> 

>> 

> 

>>> (it says there is no response from manager daemon)

> 

>> 

> 

>>> 

> 

>> 

> 

>>> Panos

> 

>> 

> 

>>> 

> 

>> 

> 

>>> -----Original Message-----

> 

>> 

> 

>>> From: Openvas-discuss

> 

>> 

> 

>>> [ <mailto:openvas-discuss-bounces at wald.intevation.org> mailto:openvas-discuss-bounces at wald.intevation.org] On Behalf Of

> 

>> 

> 

>>>  <mailto:Michael.Eissele at greenbone.net> Michael.Eissele at greenbone.net

> 

>> 

> 

>>> Sent: Monday, October 10, 2016 1:24 PM

> 

>> 

> 

>>> To:  <mailto:openvas-discuss at wald.intevation.org> openvas-discuss at wald.intevation.org

> 

>> 

> 

>>> Subject: Re: [Openvas-discuss] INTERNAL ERROR IN GSA

> 

>> 

> 

>>> 

> 

>> 

> 

>>> Dear Pano,

> 

>> 

> 

>>> 

> 

>> 

> 

>>> does this affect only one specific Report, or are there more

> 

>> affected?

> 

>> 

> 

>>> You could try deleting the Report with a Admin/Superadmin user and

> 

>> 

> 

>>> perform the same scan again afterwards, to see if the Report still

> 

>> 

> 

>>> causes an internal error.

> 

>> 

> 

>>> 

> 

>> 

> 

>>> Kind Regards,

> 

>> 

> 

>>> Michael Eissele.

> 

>> 

> 

>>> 

> 

>> 

> 

>>> 

> 

>> 

> 

>>> 

> 

>> 

> 

>>> On 10.10.2016 11:52, Παναγιώτης Λεόντιος wrote:

> 

>> 

> 

>> Hello everybody.

> 

>> 

> 

>> 

> 

>> 

> 

>> Whenever I try to access a report in GSA, I get “INTERNAL

> 

>> ERROR:

> 

>> 

> 

>> GET_REPORT:12102 (GSA 6.0.10)”

> 

>> 

> 

>> 

> 

>> 

> 

>> Does anyone know what this is about?

> 

>> 

> 

>> 

> 

>> 

> 

>> Thank you in advance,

> 

>> 

> 

>> 

> 

>> 

> 

>> Panos

> 

>> 

> 

>> 

> 

>> 

> 

>> PANAGIOTIS LEONTIOS

> 

>> 

> 

>> 

> 

>> 

> 

>> Business Engineer | Project Manager | Consultant

> 

>> 

> 

>> 

> 

>> 

> 

>> BEng, DIC, MSc, MBA

> 

>> 

> 

>> 

> 

>> 

> 

>> M: +30 6977 976269

> 

>> 

> 

>> 

> 

>> 

> 

>> E:  <mailto:leontiosp at ath.forthnet.gr> leontiosp at ath.forthnet.gr

> 

>> 

> 

>> 

> 

>> 

> 

>> B: pleontios.wordpress.com [6] [1]

> 

>> 

> 

>> 

> 

>> 

> 

>> L:  <http://www.linkedin.com/in/leontios> www.linkedin.com/in/leontios [2] [2] [1] [2]

> 

>> 

> 

>> 

> 

>> 

> 

>> T: @pleontios [3]

> 

>> 

> 

>> 

> 

>> 

> 

>> 

> 

>> 

> 

>> 

> 

>> 

> 

>> Links:

> 

>> 

> 

>> ------

> 

>> 

> 

>> [1]  <http://pleontios.wordpress.com/> http://pleontios.wordpress.com/ [1] [3] [2]

> 

>> 

> 

>> [2]  <http://www.linkedin.com/in/leontios> http://www.linkedin.com/in/leontios [2] [2] [1]

> 

>> 

> 

>> [3]  <https://twitter.com/pleontios> https://twitter.com/pleontios [7] [4] [3]

> 

>> 

> 

>> 

> 

>> 

> 

>> _______________________________________________

> 

>> 

> 

>> Openvas-discuss mailing list

> 

>> 

> 

>>  <mailto:Openvas-discuss at wald.intevation.org> Openvas-discuss at wald.intevation.org

> 

>> 

> 

>> 

> 

>> 

>   <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di

> [8]

> [5]

> 

>> [4]

> 

>> 

> 

>> s

> 

>> 

> 

>> cuss

> 

>> 

> 

>>> 

> 

>> 

> 

>>> _______________________________________________

> 

>> 

> 

>>> Openvas-discuss mailing list

> 

>> 

> 

>>>  <mailto:Openvas-discuss at wald.intevation.org> Openvas-discuss at wald.intevation.org

> 

>> 

> 

>>> 

> 

>> 

>  

>  <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis

> [6]

> 

>> [5]

> 

>> 

> 

>>> cuss

> 

>> 

> 

>>> 

> 

>>> 

> 

>> 

> 

>>> 

> 

>> 

> 

>>> -----

> 

>> 

> 

>>> No virus found in this message.

> 

>> 

> 

>>> Checked by AVG -  <http://www.avg.com> www.avg.com [7] [6]

> 

>> 

> 

>>> Version: 2016.0.7797 / Virus Database: 4664/13180 - Release Date:

> 

>> 

> 

>>> 10/09/16

> 

>> 

> 

>> -----

> 

>> 

> 

>> No virus found in this message.

> 

>> 

> 

>> Checked by AVG -  <http://www.avg.com> www.avg.com [7] [6]

> 

>> 

> 

>> Version: 2016.0.7797 / Virus Database: 4664/13180 - Release Date:

> 

>> 10/09/16

> 

>> 

> 

>> Links:

> 

>> ------

> 

>> [1]  <http://www.linkedin.com/in/leontios> http://www.linkedin.com/in/leontios [2]

> 

>> [2]  <http://pleontios.wordpress.com/> http://pleontios.wordpress.com/ [3]

> 

>> [3]  <https://twitter.com/pleontios> https://twitter.com/pleontios [4]

> 

>> [4]

> 

>> 

>   <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di

> [5]

> 

>> [5]

> 

>> 

>  

>  <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis

> [6]

> 

>> [6]  <http://www.avg.com> http://www.avg.com [7]

> 

> -----

> 

> No virus found in this message.

> 

> Checked by AVG -  <http://www.avg.com> www.avg.com [7]

> 

> Version: 2016.0.7797 / Virus Database: 4664/13180 - Release Date:

> 10/09/16

> 

> Links:

> ------

> [1]  <http://www.openvas.org/setup-and-start.html> http://www.openvas.org/setup-and-start.html

> [2]  <http://www.linkedin.com/in/leontios> http://www.linkedin.com/in/leontios

> [3]  <http://pleontios.wordpress.com/> http://pleontios.wordpress.com/

> [4]  <https://twitter.com/pleontios> https://twitter.com/pleontios

> [5]

>  <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di

> [6]

>  <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis

> [7]  <http://www.avg.com> http://www.avg.com

> 

> -----

> No virus found in this message.

> Checked by AVG -  <http://www.avg.com> www.avg.com [9]

> Version: 2016.0.7797 / Virus Database: 4664/13183 - Release Date:

> 10/10/16

> 

> _______________________________________________

> Openvas-discuss mailing list

>  <mailto:Openvas-discuss at wald.intevation.org> Openvas-discuss at wald.intevation.org

>  <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis

> cuss

> [10]

> 

> 

> Links:

> ------

> [1]  <http://pleontios.wordpress.com/> http://pleontios.wordpress.com/

> [2]  <http://www.linkedin.com/in/leontios> http://www.linkedin.com/in/leontios

> [3]  <http://directupload.net> http://directupload.net

> [4]  <https://bugs.kali.org/view.php?id=3055> https://bugs.kali.org/view.php?id=3055

> [5]  <http://www.openvas.org/setup-and-start.html> http://www.openvas.org/setup-and-start.html

> [6]  <http://pleontios.wordpress.com> http://pleontios.wordpress.com

> [7]  <https://twitter.com/pleontios> https://twitter.com/pleontios

> [8]

>  <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-di

> [9]  <http://www.avg.com/> http://www.avg.com/

> [10]

>  <https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis> https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-dis

> cuss

 

 

 

-----

No virus found in this message.

Checked by AVG -  <http://www.avg.com> www.avg.com

Version: 2016.0.7797 / Virus Database: 4664/13188 - Release Date: 10/11/16

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20161011/87e00ac3/attachment.html>


More information about the Openvas-discuss mailing list