[Openvas-discuss] openvasmd not listening on 9390 by default for OMP?

Trent Townsend trent_townsend at nextstepinnovation.com
Wed Aug 30 14:56:56 CEST 2017


Yes, in version 9 gsad listens on 80 and 9392 (80 simply serves as redirection.)  At least, that is the default way my installed using Atomic on Cent7.

Thanks for your reply - I just wanted to make sure that I wasn't crazy in having a script to start openvasmd on localhost:9390 just for OMP to work.

From: Thijs Stuurman [mailto:Thijs.Stuurman at internedservices.nl]
Sent: Wednesday, August 30, 2017 3:17 AM
To: Trent Townsend <trent_townsend at nextstepinnovation.com>; openvas-discuss at wald.intevation.org
Subject: RE: [Openvas-discuss] openvasmd not listening on 9390 by default for OMP?

Gsad listens on port 9392? That does not ring a bell for me.
Yes, something was changed from version 8 to 9 with how the services connect and listen to by default.
Personally I run a startup script with the following:

openvasmd -p 9390 -a 127.0.0.1
gsad -p 443 --listen=0.0.0.0 --mlisten=127.0.0.1 --mport=9390 --ssl-private-key=priv.key --ssl-certificate=pub.crt --http-sts --gnutls-priorities="NORMAL:-VERS-TLS-ALL:+VERS-TLS1.2:-CIPHER-ALL:+AES-256-CBC"

If you want to use omp though IP you have to indeed tell openvasmd to listen.
*openvasmd is to be renamed to gvmd in the future; you'll have to adjust your startup script then.


Thijs Stuurman
Security Operations Center | KPN Internedservices
thijs.stuurman at internedservices.nl<mailto:thijs.stuurman at internedservices.nl> | thijs.stuurman at kpn.com<mailto:thijs.stuurman at kpn.com>
T: +31(0)299476185 | M: +31(0)624366778
PGP Key-ID: 0x16ADC048 (https://pgp.surfnet.nl/)
Fingerprint: 2EDB 9B42 D6E8 7D4B 6E02 8BE5 6D46 8007 16AD C048

W: https://www.internedservices.nl<https://www.internedservices.nl/> | L: http://nl.linkedin.com/in/thijsstuurman

Van: Openvas-discuss [mailto:openvas-discuss-bounces at wald.intevation.org] Namens Trent Townsend
Verzonden: dinsdag 29 augustus 2017 20:07
Aan: openvas-discuss at wald.intevation.org<mailto:openvas-discuss at wald.intevation.org>
Onderwerp: [Openvas-discuss] openvasmd not listening on 9390 by default for OMP?

Good afternoon,
  One thing I've noticed about my new OpenVAS 9 install on Cent7 is that gsad only listens on 9392 and 80.  Openvasmd isn't listening on 9390 like it did in my OpenVAS Cent6 installation (I think it was version 7 but I'm not sure).  To run omp commands, I'm forced to manually kick off openvasmd -listen=127.0.0.1.  I don't mind doing that but I'm wondering if anyone has seen this and if that is expected behavior.  Thanks in advance.

Trent




________________________________
This email is confidential and intended solely for the use of the individual to whom it is addressed. Any views or opinions presented are solely those of the author, and do not necessarily represent those of Next Step Innovation. If you are not the intended recipient, be advised that you have received this email in error, and that any use, dissemination, forwarding, printing or copying of this email is strictly prohibited. If you have received this email in error, please contact the sender.
________________________________



This email is confidential and intended solely for the use of the individual to whom it is addressed. Any views or opinions presented are solely those of the author, and do not necessarily represent those of Next Step Innovation. If you are not the intended recipient, be advised that you have received this email in error, and that any use, dissemination, forwarding, printing or copying of this email is strictly prohibited. If you have received this email in error, please contact the sender.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/openvas-discuss/attachments/20170830/ce1a4534/attachment.html>


More information about the Openvas-discuss mailing list