[Openvas-distro] resolv error during configuration step of openvas-libraries source install

Randal T. Rioux randy at procyonlabs.com
Tue Dec 23 08:58:31 CET 2008


Thread awakening! Moved here to -distro from -discuss. See comments inline.

> On Tuesday 17 June 2008 17:26, Jonathan Glenn L. Ocab wrote:
>> I was looking into installing Openvas under Solaris 10 x86. I had
>> already gotten Nessus 2.2.11 compiled and built on that same box, but
>> wanted to give Openvas a whirl since it is more maintained than the
>> older Nessus 2 branch.
>>
>> Unfortunately, during the compile of the openvas-libraries package, I
>> have been stonewalled with this error during the configuration:
>>
>> checking for __dn_expand in -lresolv... no
>> configure: error: you need to install resolve library with development
>> files

Same error on SPARC platform here.

On Tue, June 17, 2008 3:14 pm, Jan-Oliver Wagner wrote:
> seems this check does not work on Solaris.
> Perhaps some of the other Solaris guys around can help.
> I do not have a Solaris at hand to play with.

I just created the following bug report:

[#857] configure failure on Solaris 10 SPARC

If anybody else has an idea, let me know. Otherwise I'll fudge with it more.

Thanks,
Randy




More information about the Openvas-distro mailing list