[Openvas-distro] oO openvas-libraries-2.0.0.beta2 requires glib-2.0 >= 2.2.0
michael.wiegand at intevation.de
Tue Nov 18 08:20:04 CET 2008
* Stephan Kleine [17. Nov 2008]:
> Hi folks.
> I today tried to build Beta 2 packages and failed cause it claims that
> glib-2.0 >= 2.2.0 would be required.
> Are you serious about this? Even openSUSE 11.1, which will be released
> in december, only contains glib2-2.16.1 and I kinda doubt that there
> are any other distros that come with 2.2.x.
I've seen you've figured it out yourself, sorry for the confusion. :)
For everybody who was wondering: The glib minor version numbers go
beyond 9, so version 2.16 is indeed newer than version 2.2.
Version 2.2 of glib was released in August 2003 AFAICT; at least this
version should be available on all major *nix platforms.
Version requirements for glib might rise in the long run, especially as
we prepare to replace cruft in the code with glib implementations. But
at least for the OpenVAS 1.0 and 2.0 series, glib 2.2 will be
But I can understand the configure error message might have lead to Stephans
misunderstanding, I'll try to improve that (again). Any suggestions?
Michael Wiegand | OpenPGP key: D7D049EC | http://www.intevation.de/
Intevation GmbH, Neuer Graben 17, 49074 Osnabrück | AG Osnabrück, HR B 18998
Geschäftsführer: Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner
More information about the Openvas-distro