[Gpg4win-users-en] Trouble importing private key

Stephen Brown stephen.brown75 at gmail.com
Wed Jun 15 17:59:43 CEST 2011

Hash: SHA1

Well after much wrangling, I FINALLY got this to work!

Thanks to all who replied, I ended up taking the route listed below. It
was a combination of user error and corrupt files :)


On 6/14/2011 4:28 PM, Charly Avital wrote:
> Stephen Brown wrote on 6/14/11 3:27 PM:
>> I have a keypair that was created in OSX that I used to sign and encrypt
>> mail. If I attempt to import my private, I get the following error:
>> C:\Users\sbrown\Desktop\keys>gpg --import secring.gpg
>> gpg: [don't know]: invalid packet (ctb=00)
>> gpg: read_block: read error: Invalid packet
>> gpg: import from `secring.gpg' failed: Invalid keyring
>> gpg: Total number processed: 0
>> Any ideas? I've been working on this for a couple of hours now and can't
>> put a finger on it....
>> I'm running Windows 7 Pro 64-bit and the latest version of gpg4win.
>> Thanks,
>> Stephen
> Hi Stephen,
> I run MacGPG2-2.0.17 and gpg 1.4.11 on MacBook Intel Core 2 Duo under
> MacOSX 10.6.7, and gpg4win (gpg 2.0.17) on an Acer under Windows 7 Home
> Premium 64-bit.
> When I transferred my keyrings (public and secret) from the Mac to the
> Acer, I used an USB memory stick.
> I had no problems importing all my OSX keys.
> You didn't indicate how you transferred your secring.gpg from one system
> to another, but my wild guess is that in the processing of copying from
> one system to another, your secring.gpg got corrupted e.g. additional
> lines were added to the secret key keyblock, or any other anomaly.
> If you haven't tried this yet, let me suggest the following:
> 1. Remove (rename, or delete, or move to a neutral location) the
> secring.gpg that exists now under Windows 7.
> 2. Run the gpg4win installer so that it overwrites you current installation.
> 3. Use a physical media (an USB memory stick is the easiest to use IMO),
> to transfer your OSX secring and pubring from one system to another.
> 4. Try to import again. It's important that the command
> --import secring.gpg includes the complete path to secring.gpg
> e.g.
> --import [path to]secring.gpg
> I apologize in advance for maybe wasting your time.
> Charly

Version: GnuPG v2.0.17 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Gpg4win-users-en mailing list