[Gpg4win-users-en] pinentry.exe crashes in GPG4Win-Light on Windows 7 Prof. with Russian locale

Ivan Krylov krylov.r00t at gmail.com
Sat Nov 2 20:20:32 CET 2013

Hi and thanks for your replies!

(sorry for sending it wrongly for the first time, I confused "reply"
button with "reply to all")

Bernhard Reiter wrote:
> is this better with the full Gpg4win (that possibly uses pinentry-qt4)?
Well, I should have thought of that earlier. Installed Full version with
GPA checked, that worked normally!

> Then we could try to qualify the report further, e.g. by
> a) trying to create an easier reproduction, like a calling pinentry directly
>   pasting in some characters and then have the crash. 
> http://info2html.sourceforge.net/cgi-bin/info2html-demo/info2html?
> (pinentry.info.gz)Protocol
> call pinentry directly and get it to crash
>    pinentry.exe
>    SETDESC hi use utf-8 encoding like %25
I failed to make pinentry.exe crash manually, no matted what I asked it
to display. I also tried to write a program to replace standard
pinentry, read STDIN and ask me interactively what to reply to it, but
couldn't make gpg-agent run a perl script like a normal executable with
stdin and stderr connected where they belong.

But that probably doesn't matter, see below.

> b) trying to get a debugger backtrace of the crash
> If you like to join the development list, this is where we can help people 
> better when stuff gets more technical. :)
If nothing else helps, I'll join Gpg4win-devel, try to get gdb working
on my Windows machine, get the version with debug symbols and acquire a

Or are we already too technical? :)

Werner Koch wrote:
> Regarding the crash, it seems that the Qt pinentry is installed as the
> GTK pinentry seems to work.  Please do this:
> Swicth to the GnuPG directory: In the shell something like
>   c:
>   cd \progr....\GNU\GnuPG 
> or use the explorer.  Then open a shell (cmd.exe) and run
>   pinentry --version
> What is the reported version?
"pinentry-gtk2 0.8.4-beta8", just like pinentry-gtk-2.exe. In fact,
pinentry.exe is the same as pinentry-gtk-2.exe (checked with 'fc'), but
saying "pinentry-program ...pinentry.exe" in gpg-agent.conf does not
make it work.

Furthermore, pinentry-w32.exe exits immideatly on startup if run from
cmd and does not respond to --version, but if I rename it to
pinentry.exe without creating gpg-agent.conf, it does work properly
(being called from gpg-agent, not manually).

P.S. Stopped to recheck what I wrote about pinentry-gtk-2.exe and
realised that "pinentry-program ...pinentry-gtk-2.exe" solution stopped
working too.

Rewrote my logging pinentry in C (source attached), but if run from
gpg-agent, it just truncates the log and hangs despite looking
identically to pinentry-gtk-2.exe when run from cmd.exe.

Best regards,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: pinentry.c
Type: text/x-csrc
Size: 733 bytes
Desc: not available
URL: <http://lists.wald.intevation.org/pipermail/gpg4win-users-en/attachments/20131102/f71de795/attachment.c>

More information about the Gpg4win-users-en mailing list