[Gpg4win-users-en] GPG Encryption Fails When Called From Oracle Enterprise Manager

Kent Hurtig kent_hurtig at friends.edu
Tue Jul 7 17:52:51 CEST 2015

Hi gpg4win users,

I have created a batch job that encrypts a file using GnuPG software.  When I run the batch file from the server where the file resides, it runs successfully and encrypts the file.  When I run the batch job through Oracle Enterprise Manager(the software that we schedule our batch jobs through), the task which encrypts the file using gpg encounters several issues.  I have attached the output from this task.  I should mention that I previously had the same issue on our old "Media" windows server 2003.  To correct the issue, I changed the gpg command to be more verbose and saw that the process was being ran as the default user and not as user aunt_bee.    I copied the gpg.conf, pubring.gpg, secring.gpg, trustdb.gpg and trust.gpg.lock from C:\Documents and Settings\aunt_bee\Application Data\gunpg to C:\Documents and Settings\Default User\Application Data\gnupg on Media, reran the Oracle Enterprise Manager job and it finished successfully.

Our new server is a windows server 2012.  There is no default user on the new server.  Please advise.

Best regards,

Kent Hurtig
Friend's University
kent_hurtig at friends.edu<mailto:kent_hurtig at friends.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wald.intevation.org/pipermail/gpg4win-users-en/attachments/20150707/6813f5ed/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: TASK4 Error Messages.txt
URL: <http://lists.wald.intevation.org/pipermail/gpg4win-users-en/attachments/20150707/6813f5ed/attachment.txt>

More information about the Gpg4win-users-en mailing list