[Gpg4win-users-en] An error occurred while trying to add the user-id: General error

Ken kmailuk at googlemail.com
Wed Apr 21 17:10:52 CEST 2010

Hmmm... Now I opened Thunderbird, did a few things, and then in
Kleopatra I tried:

(1) To change the passphrase of a key and got the message:
An error occurred while trying to change the passphrase.
The output from C:\Program Files\GNU\GnuPG\gpg2.exe was: gpg: problem
with the agent: No pinentry

(2) For another key I tried to change the expiry and got the message:
An error occurred while trying to change the expiry date for DELETED
General error

I will try again when I next reboot the my computer.

2010/4/21 Ken <kmailuk at googlemail.com>:
> Two minor things I have noticed playing with Kleopatra:
> (1) When the system requires PIN entry it does not let me Paste (i.e.
> no right-click or Ctrl-V).  Pasting would be useful as I store very
> long pass-phrases in a password safe on a USB drive and are tedious to
> type.
> (2) When I select "Change Passphrase" and then hit Cancel at the
> Pin-entry stage, the dialoge box sayts "Passphrase successfully
> changed" although it has not been.
> Ken
> 2010/4/21 Ken <kmailuk at googlemail.com>:
>> Hi Emanuel,
>> Your steps worked without any problems for me.  I was also able to
>> change the expiry date.  I am trying to remember what I did the last
>> time when it failed. I believe I was doing this through Thunderbird.
>> I'll try again and update you if I encounter this error again.
>> Thanks for your help.
>> Ken
>> 2010/4/21 Emanuel Schütze <emanuel at intevation.de>:
>>> Hi Ken,
>>> On 13.04.2010 12:13, Ken wrote:
>>>> I am running recent installation of gpg4win 2.0.2
>>>> When I click on one of my certificates and choose to Add-Id, I enter
>>>> an email address and hit ok.
>>>> I then get the error message:
>>>> "An error occurred while trying to add the user-id: General error"
>>>> (This is not a helpful message). The User-Id is not added to the
>>>> certificate.
>>> Thanks for reporting!
>>> But I can't reproduce it with gpg4win 2.0.2 (on a fresh WinXP and Vista
>>> installation):
>>> Adding a new user-id of an OpenPGP certificate works fine for me.
>>> Can you try again this test:
>>> * Create a new OpenPGP test certificate with Kleopatra.
>>> * Select new certificate
>>> * Run "Add user-id..." from context menu
>>> * change name and email-address
>>> -> Kleopatra shows message dialog: "User-ID successfully added."
>>> Does this test work for you?
>>> If you get an error please enable Kleopatra log for this test:
>>> Instructions (German only, sorry):
>>> http://gpg4win.de/doc/gpg4win-compendium-de_29.html
>>> Add two ENV vars:
>>> * KLEOPATRA_LOGDIR, value: e.g. "c:\TEMP\kleologdir"
>>> * KLEOPATRA_LOGOPTIONS, value: "all"
>>> Interesting log file is "kleo-log". You can send us this file.
>>> Regards
>>> Emanuel
>>> --
>>> Emanuel Schütze  |  ++49-541-33 50 83 - 746  |  http://www.intevation.de/
>>> Intevation GmbH, Neuer Graben 17, 49074 Osnabrück | AG Osnabrück, HR B 18998
>>> Geschäftsführer: Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner

More information about the Gpg4win-users-en mailing list