[Gpg4win-users-en] gpg-agent scdaemon + yubikey smartcard not asking for PIN with PUTTY

Bowlers Bloody bloodybowlers at gmail.com
Thu Mar 24 15:04:18 CET 2016

>> I tried older version (which, at the time, worked for people with the
>> same setup as myself), but I can try new version too of course.
> That is helpful, because development right now is concentrating more
> on Gpg4win 3 with the new GnuPG 2.1 (to become 2.2) and this is where
> gpg-agent and pinentry is handled slightly differently. So making sure that
> it works with the new version is better for the future.

Ok, I installed gpg4win 3.0.0 BETA 128.
The problem stay the same, no pin is asked.

In the mean time, I tried this tool : http://smartcard-auth.de/ssh-en.html
It replace the pageant.exe that ships with putty. And it works. When I
log on the server with putty, I got asked for the PIN. So I think this
is not a problem with the smartcard or with keys. It seems that it's
only that gpg-agent doesn't trigger the pinentry.

I tried on another computer (fresh install) running Windows 7 x64, and
with another smartcard, same problem.

More information about the Gpg4win-users-en mailing list