[Gpg4win-users-en] problems with 2.2.5

Juan Miguel Navarro Martínez juanmi.3000 at gmail.com
Sat Jul 18 17:59:44 CEST 2015

On 2015/07/18 at 17:24, g4 at novadsp.com wrote:
>> gnupg folder is indeed owned by Administrators, but all files and private-
>> keys-v1.d are owned by my user.
> If I was being a stickler :), I'd suggest that this is wrong. 
> The folder is being created in the users data directory structure and
> ownership should reflect this.

I don't remember if the folder was created during the installation,
which no matter which way, it asks you for Admin privileges, which
"makes sense" for gnupg to be owned by Administrators group or after the
first gpg2 command which then it doesn't.

>> I could create two RSA master keys with a RSA subkey with no permission
>> issues.
> Hmm. Sadly the existence of one positive does not negate the negative .... 
> How are you generating the certificate, and if in a shell, from which
> folder?

At first I did the normal thing: Open CMD normally and use gpg2
--gen-key to generate a key using the RSA and RSA option: All good.

I deleted everything from the gnupg folder, and then used CMD with
elevated privileges, and created a key successfully. Then exited from
CMD, and reopened it with no elevated privileges and tried to create
another key, and it was successful again. I noticed that all the files
were first owned by the Administrators group at first, then it changed
to my user after the second key was created.

Lastly, I created a standard user, it had no gnupg folder. I used gpg2
--gen-key the same way and it created the keys successfully again, but
this time 'gnupg' folder was owned by the user instead of the group

> At the very least Kleopatra should display the error message generated by
> gpg2. 

I haven't tried the Kleopatra way, but I'll assume it should work. I
will try it after the making of this email.

> It's a real shame as the rest of the package works exactly as expected. 

I guess it's time for developers or any contributors to help you now. I
would recommend to use `gpg2 -vvvvv --debug-all --gen-key` or `gpg2
-vvvvv --debug 1024 --gen-key`. I don't know if both are the same or the
first one is better, but it should give the developers, and maybe you as
well, better information.

Juan Miguel Navarro Martínez

GPG Keyfingerprint:
5A91 90D4 CF27 9D52 D62A
BC58 88E2 947F 9BC6 B3CF

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: OpenPGP digital signature
URL: <http://lists.wald.intevation.org/pipermail/gpg4win-users-en/attachments/20150718/35b87c08/attachment.sig>

More information about the Gpg4win-users-en mailing list